Making Lofting Geometry Error


I was following this tutorial vid and for some reason there are some odd shapes created around the cylinder-like shape that I wanted to make. Not very sure which part went wrong. Is there any way to solve this?

Thank you!


Link the tutorial video and upload Gh file.


Lofting (13.7 KB)

Curves not Internalized in your file.

This what i get. How to Internalize data.

I right clicked on curves and selected internalise data. Nothing has changed though. Did I do it wrongly haha?

Hmm it looks normal on my file rn tho, as shown in the previous png image

I completely recreated the definition/ script you’re looking for. If you need this file just upload your attempt file with proper internalized data. After you upload the proper file you will get this.


Not sure if this is correct but I just selected internalise data for all the inputs the two curves were connected to and then deleted the curves like shown in the video. And ya I would like to have the file if possible haha.

Lofting Geometry.3dm (208.6 KB)
Lofting Geometry (Internalised Data).gh (14.2 KB)

Haha. You passed test I guess. (But I didn’t yet check your new script :stuck_out_tongue_winking_eye:)

YouTube (42.8 KB)

Thank you. Btw can I ask how did you make it? Cuz I copied it and tried to assign to new curves and the same problem is happening again.

Upload your screen recording here.

Ahh my laptop wont record GH for some reason. Basically I made a new model in rhino (same as tutorial vid), assigned the two circles to two new curves. Then I connected the two curves to Tween Through Curves and Merge before I deleted the old curves. After that I selected the two curves, right clicked and selected internalise data.

Hi -

What BVR neglected to tell you is that internalizing data won’t do you any good for solving your problem locally on your machine. Internalizing data is used to make a Grasshopper definition independent from a Rhino file by copying referenced Rhino geometry into the Grasshopper file. Doing this makes it possible to run the definition on a different machine that doesn’t have access to the Rhino file.

I suppose that you internalized data in the file that you posted, but because you internalized it in the “wrong” place, I can’t tell. You should internalize it in the parameter that collects (references) the Rhino geometry, not at the input of a downstream component. Technically, there’s nothing wrong with doing it the way that you have done it because one could always extract the parameter again. Only, in your case, you are using a component that is not part of the standard Grasshopper library. I do have Pufferfish installed here but apparently that’s a different version and the Tween Through Curves component that you used shows up as unknown here:

(In that picture, I have inserted the Tween Through Curves component that I have installed - it has 1 less input than the one that you used).

Because of this, I don’t have access to the curves that you have internalized and therefore used the curves that BVR internalized in his file.

Now to this:

You had also internalized the D1 and D3 inputs of the Merge component:

Since that component is a standard part of the Grasshopper library, I get those curves but since BVR’s curves are unrelated, this has the following effect on my machine:

Exchanging these curves with the ones that BVR used, gives me this:

… which is pretty much what you are showing in your first picture.

To solve this, you should simply switch the inputs for D1 and D3 so that the curves are in the correct order to be lofted: