Grasshopper Loft from curves not lofting

need to loft the selected curves generated from the kaleidoscope ( sorry for spelling ) component in grasshopper but that seems to be not happening, if anyone found this can you please help me, new to learning gh

I’ve attached the desired result which I manually did on rhino but need to automate in GH

here’s the screen shot

here’s the GH script
Kaliedoscope exper 1.gh (25.2 KB)

seems like i have problem understanding what geometries can be lofted via GH, open curve VS closed curve lofting, any other alternate solutions to loft when curves are not closed

please open your GH file together with your Rhino file, internalize the geometries (right click on the initial Curve parameter and chose “internalise data”), save the file again and reupload it

they were stored, my bad, apologies

heres the script
Kaliedoscope internal curve stored.gh (24.3 KB)

it looks like a Tolerance issue, as if the scaling operation -despite being small factors- is opening your closed curves…

this with tolerance 0.001

this with tolerance 0.0000001

never happened to me before .___.

Here’s a trick to do what I think you’re looking for:

Extrude.gh (12.3 KB)

Thank you Birk Binnard for you time, appreciate your help for helping new-comers!,