Problem setting height and width with Beam

I’m testing VisualArq but I have some problem setting width and height of a custom section (very complex, with multiple paths). Every time a tryed, Rhino gone crazy. Attached file and error

custom_section_01.3dm (746.7 KB)

Hi @flecheria,

I’ve been able to reproduce the bug and I’ve already fixed it. The fix is included in VisualARQ 2.0.14, that will be released later today.



Hi, yes the bug is gone. Perfect!
But the new value has scaled all the profiles in one dimension. What I need to do is:
"Hey VisualARQ, consider all these profiles one single entity, with dimension 50x241.76"
Because I need to control the beam alignment for the global section.

By the way, it seems that VisualArq take the dimensions of the first curve selected during the creation of the custom profile with ProfileFromCurve.

It should be very helpful have more control on the specifications of the Beam profile.

More or less the same result is possible using multiple Profile and multiple beam, but put all in place could be cumbersome…

See the file with the distorted proflle…

custom_section_01_update.3dm (695.5 KB)

Hi @flecheria,

The problem is that VisualARQ custom profiles must only contain one single exterior loop, and then a list of interior loops that define holes. But it seems that the command “vaProfileFromCurve” allows you to select multiple exterior curves.

I’ll create an entry in our wish list to add support for multiple exterior loops. In the meantime, you should use multiple beams, or don’t take into account the wrong value shown in the “height” property.


That’s ok. Thanks