Problem Installing Rhino 7 MacOSX Big Sur


does anyone knows why I get this error on my mac (Big sur), trying to install the Trailversion of Rhino 7?
See the picture (it´s german, means in english: The action could not be completed because you do not have the necessary access rights for “Rhino 7”.


Do you have local Administrator rights on that Mac?
Apple requires that for installing applications.

Yes, I´m Admin.

have the same problem.
I can’t install the update (Mac Monterey)
in want install rhino 7 new, it doesn’t work. :frowning:

on my MacBook Pro (Catalina) the update also doesn’t work, same problem.

Is Rhino running when you’re trying to drag the new build into Applications?

start to load… after that, the message with the problem.

Maybe a damaged download?
I’m just guessing.

Have you tried downloading the current DMG from the Download page and trying again?

sure. I tryed.
funny, I installed the wip now, it works…

on my MacBook (Catalina) and rhino is installed.
when I start rhino, rhino ask me for the update… also the problem (with an installed rhino 7)

I read in a forum that Apple suggests reinstalling the whole mac. : / (clean install)

I did that today and rhino 7 can be installed without any problems.
wtf …
no idea why the rights are different now than before …?

I have a client reporting the same thing today - any solution?

No way that I will give my client the advice that they need to do a clean install of their MacOS in order to install Rhino…

I would recommend doing two things first:

If those two things do not work, please attempt to copy the Rhino to your Desktop (drag it to your Desktop instead of the Applications folder) and see if it is allowed to be copied there.

Unfortunately, I haven’t found a better alternative. after a day of unsuccessful installation Rhino 7 on my Mac Pro 6.1, i gave up. then I reinstalled (monterey). then the Rhino installation worked.
I don’t understand the problem either.
I don’t want to have to re-install my macbook pro (catalina). rhino 7 is installed, but the update does not work. same problem.
I am happy if someone finds the problem.

You didn’t explicitly say if you tried Dan’s suggestion of running the Disk Utility > First Aid, and restarting your Mac.

Did you try that?

Hi Dan,

I already have Rhino 7 installed on my MacBook and want to update Rhino 7. Unfortunately that does not work.
(Macbook Pro 2015, macOS Catalina 10.15.7)
Rhino Version 7 (7.10.21256.17002, 2021-09-13)

I followed the suggestion:

Attempt to clean up potential permissions issues with Disk Utility> First Aid 1
Restart your Mac.

After that, the update still did not work.

Then I tried the second suggestion:

I copied Rhino 7 to my deskscreen, but that didn’t work either.

Installing over the old version does not work either.


sorry for my reply / message to Helvetosaur. I replied to the email from my mail app, so I didn’t see that Dan was writing.

I’m trying to recall if I have seen an instance of this from someone running macOS in English. Since we cannot reproduce this on our end, perhaps we need to test when running in French or German.

Is anyone here familiar with I’d be curious if we can see any additional error information provided by macOS in Console when this copy step is happening. “Installing” Rhino for Mac is really just a copy operation - it just copies the Rhino bundle (a bundle is a folder) to another disk location; we’re not running any of our code here. However, it is possible that there are contents in the app bundle that have permissions that are causing this error for some people.

This really leads me to believe this is a macOS update issue. Perhaps there’s still something we can do to avoid it - something non-standard we are doing that is causing macOS to really not like the permissions.

That’s what I was wondering - I only see reports of this problem on non-English systems here so far…

Hi Mitch, I have been struggling with the same problem these past two days. I suspected it could be a language version thing so I restarted in English. I even tried downloading from the english rhino page and I tried copying from the Terminal (tried cp and install). I didn’t tryst in superuser mode though. No change…

@dan I tried booting in recovery mode, DIskutil > first Aid booting again (OS in English), same result.

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro11,5
Processor Name: Quad-Core Intel Core i7
Processor Speed: 2.5 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Hyper-Threading Technology: Enabled
Memory: 16 GB

System Software Overview:
System Version: macOS 11.6 (20G165)
Kernel Version: Darwin 20.6.0
Boot Volume: Macintosh HD
Boot Mode: Normal

@dan Just an additional info: Rhino 8 WIP installs without a problem. Maybe it helps?