Problem importing .step made in SolidWorks

Hi I have a problem importing .step files made in SolidWorks. when I open them in Rhino they are buggy and filled with errors. but in other SW programs they still open as intended.

Can it be my import settings (using Rhino 5) or the SW export settings?

Unfortunately its a work related file so i dont have permission to “share”

It’s supposed to look like this:

But it opens like this. And its not just because some of the sides are not trimmed, they are warped and deformed.

Hi Rasmus - without a sample file, there’s not much we can do.
If possible, please use the following page to upload a confidential file. Make sure to add a link to this thread in the Comments field on that page.
https://www.rhino3d.com/upload
-wim

Hi Wim

I need to enter an email to whom im sending the file. what should I use here?

Hei Rasmus - you can use tech@mcneel.com.
-wim

Hi I have uploaded the file now, its a drawing for a injection mold so its relative complex.

“Main problem is the part in layer 5” there are also other problems but this is the one i have referred to above.

have you tried opening the SW file directly? Otherwise also try as iges. I often get these kind of issues on imports from SW

Hi Rasmus - I should have waited until you identified the layer in your edit of the post but I managed to eventually find that part : )
At any rate, I see the same problem as what you show in your picture in Rhino 5.
Importing this file into Rhino 7 works fine, though:

There are issues in other parts (also in Rhino 7) but they all seem to be related to “cosmetic threads”. Back in the days, when I worked in Pro/E, these would import via STEP as unattached surfaces (cylinders) around holes. In your file, if that’s what they are, these are modeled as actual sloths with ID 7.985 mm, OD 8.000 mm and depth 16 mm. I take it that’s not something that’s being machined?
-wim

I agree with Gijs, try exporting to IGES from SolidWorks. I have found the same problem. STEP often has failed surfaces and IGES comes in clean.

Hi Gijs and Mark

Thank you for the suggestion on .iges

I found that for my type of work the .iges format is not optimal.
( I can be wrong, and it’s just me who does not export correct! )

I work whit injection molds so my files are relatively big and the .iges format is mostly 3-4 times bigger in file size.

Also the fact that .iges splits every thing in to surfaces gives me a big management problems.

Hi Wim

Thank you for taking the time and sorry about the layer, though I did a pretty quick edit.

Do it open correctly in Rhino 6 or only in 7?

As mentioned above by Gijs are there any chance that importing from solidworks native files vill have les errors?


I assume this is the “cosmetic threads” you are referring to, its a “reminder” for making space for a later added thread. so that I dont put something else to close to it.

The cosmetic errors I can work around. my main problem is the surfaces that gets “redrawn/ changes value” Are there any way to get Rhino to tell me where the changes were made or do Rhino in general se the errors as correct.

(ShowEdges) will point to some of them, but naturally only where the edge have detached. if its warped but still solid i cant see it.

Hei Rasum,

I know : )

I now tried in Rhino 6 and it looked the same as it does in Rhino 7.

That’s correct, yes.

It’s a bit unclear to me what is what in all this.

As far as I can tell, the issue with your way of inserting the “reminders” is causing the only issue with importing that STEP file into Rhino 6 or 7. In your picture, the top and bottom faces are not meshing correctly. But there are no errors in that face. If you extract it and apply a really fine mesh to it, it will mesh correctly. I’ll put it on the list to see if anything can be done about that - RH-59178.

There is some checking when importing files and if an object is found to be “bad”, you will get a warning. But “bad” on a geometry level and “bad” for the user doesn’t always coincide.

And again, I didn’t find any “surfaces that get “redrawn / changes value”” when imported into Rhino 6/7.
-wim

Hi Wim

Thanks for the comments. if the deformation isn’t present in Rhino 6/7 I’ll properly just have to upgrade.

Regarding the cosmetic threads. The main projekt moves around to other people aswell, so there needs to be a indication on where the threads are being processed. I cant remove them completely. But as long as its just “cosmetic” Ill work around it.

Of course it would be optimal if the glitch wasn’t there :wink:

Again thanks for the help.

Hi Rasmus

Have you been able to solve the problem?
Especially with complex STEP data (file in screenshot = 300 MB) I have big problems.

The problem is independent of the Rhino version (tested with Rhino 5 and 6 / Mac).

The problem also exists when importing into Fusion 360, so it seems to be the export of Solidworks and not the import of Rhino.

The following posts from the Solidworks forum might solve the problem: https://forum.solidworks.com/message/1004255?q=step
https://forum.solidworks.com/message/991877

Hi dan_kray

Thank you for the comment, no I haven’t solved it yet. But what I understand from Wim an upgrade to Rhino6 would remove the problem!

(I havn’t don the upgrade yet, because I have a project deadline in three weeks so cant risk messing around whit a “new” program. So cant say if it actually did solve it )

As I can read from your linked SW posts it looks like the “Split Periodic Faces” option can help on the problem when exporting from SW.

I am not 100% sure I fully understand what the feature do. this was the best description I could find of it. https://www.simscale.com/forum/t/meshing-tip-split-periodic-faces/108

My main concern about the feature, if i understand it correctly. Is that it will “warp” the faces to match more perfectly, and if so how will this affect the true geometry of the shape.

Even with Rhino 6 there are exactly the same faulty surfaces.

I have asked my customer to re-export with the recommended settings and will gladly give feedback as soon as I have checked the data.

The following workflow solves the problem:

  • Export from Solidworks as Parasolid
  • Re-import the Parasolid to Solidworks
  • Export as STEP from Solidworks
  • Import the STEP in Rhino

Hi Dan -

Thanks for that. That really looks like a SolidWorks issue.
The STEP file that Rasmus sent, though, didn’t have problems like the ones that you have showed here.
-wim