IGES or STEP Import from SolidWorks

Can anyone advise what the proper settings should be in SolidWorks to create an IGES or STEP file for export to Rhino V5. I’m having trouble getting 3D files to come in clean (no screwed up surfaces to repair) from our Engineer who’s working on SolidWorks.

Michael D.


Why don’t you open the SW file directly in Rhino? I find it works pretty well…


1 Like

Not so much for assemblies. I find the different parts tend to pile up at world 0. Maybe it’s something they are doing in Solidworks that causes this? I don’t know. We use STEP for assemblies to avoid this. However, for individual parts, the Solidworks importer works well.


Dan - do you import the assembly file? Been awhile since I did one of those, I usually end up with individual part files anyway.


We found out pretty early on that we couldn’t import assemblies from Solidworks directly. STEP has worked very well for us.

My only complaint is that since V5, the object names coming from Solidworks are being lost when the blocks are exploded. I wrote a script to take the block name and re-apply it to the object after exploding.


Hmm, hopefully that could be fixed… I think they’re using the DataKit plug-in to import SW files, probably something that needs to be fixed by them…


Dan, have you complained to us about import of SW assemblies?


I don’t recall, but I’m thinking probably not. At the time our Solidworks people were pretty new at it and I may have chalked it up to them and their crazy configurations. STEP was an easy solution and we’ve gone with it ever sense.


OK, thanks- at least I wasn’t ignoring something… if you do run into an example, send it along, if you can.


I’ll find some files that aren’t too big. I guess speed is another reason we stick with STEP. Importing a Solidworks file anything more than a few Mb is painfully slow. I’m importing a 25Mb file now, which I consider fairly small, and it took 12 minutes. The STEP took a bit less than 1 minute.

OK- I’ll see if I can find out why that might be. Thanks.
@lowell, any idea why that might be so slow compared to STEP?


It seems to me that if there are any Solidwork’s attempts at handling surfacing, that’s where the bog originates. Take out the surfacing and it seems to be quicker.


I tested a 45Mb SWX assembly, which includes a CAD file imported from our customer. It took 21 min, 40 sec to import into Rhino, and the results were unusable:

I had one of our SWX guys remove the part, and the file imported into Rhino in 2 min, 4 sec. It was better, but there are still objects out of place (and not even supposed to be there):

When I imported the STEP file (that doesn’t have the customer part), it took 37 seconds, and imports perfectly:

All we do is import the customer file (which is always saved in Rhino format anyway) and we are good to go. Total time less than 1 minute.

1 Like

I don’t know about the comparison of Solidworks to STEP import speed.

On some Solidworks files, quite a bit of time is spent trying to patch up
seams and validate polysurfaces.
The first try is to read all of the geometry and joining topology and make
a good polysurface.
If the initial construction makes a polysurface with seams not joined or
surfaces missing or whatever, there’s a general repair tool that they get
run through to try to fix them up.

Sometimes Solidworks files have a lot of data that isn’t active or is
metadata of some kind, but I don’t think sorting that out takes too long
compared to making polysurfaces.

Other than that, I’d have to look at specific cases to see where the time
is being taken up,

Lowell Walmsley
Robert McNeel & Associates

I noticed that the Solidworks STEP file above was coming into Rhino with separate layers.

Unfortunately, my Solidworks STEP file is coming in to Rhino all on one layer. Are there any recommended settings for exporting from Solidworks STEP that my collaborator can use?

Take another look. It was the Solidworks import that had a variety of layers. The STEP file comes in all on the same layer.


Ahhhh… I see that now. Bummer!

I’ve been working with a lot of STEP files lately exported from Solidworks and nearly every part comes in with naked edges and flipped normals. The first pass is to reduce the tolerance (usually imported at 0.0001 mm) and then explode and rejoin all surface. This takes care of 90% of the naked edges. The rest I have to fix manually. In many cases it’s a tiny edge, barely a point when zoomed out, so I will export to STL and let Netfabb do the repair. Other times there are gaps you could drive a truck through.

I’m curious why this happens and have formed the opinion that it’s probably Solidworks since the STL files it exports also need repair. Does Solidworks brute force fillets and other features by bodging the edges? Is it due to the difference in workflow between solid modelling and surface modelling?

Hi Ashley -

It is always worth at least trying the test command testRemoveAllNakedMicroLoops on these objects. (Test commands are unsupported, and do not autocomplete… use at your own risk)


1 Like

That helps. It got one model from 17 naked edges down to 8. Then explode and join again reduced it to 5.