Printed materials don't match display

unhandled

#1

If I have a custom type material that has an image applied in the color slot, and the material either has the color value or transparency set less than 100%, it will print and print preview as if these values were set at 100%, even though the material displays correctly in the viewport.

Thanks,
Sam


(Pascal Golay) #2

Hi Sam - I tested this here and I got the expected results … can you please run SystemInfo (Help menu > System Information, and paste the results here?

-Pascal


#3

Rhino 6 SR4 2018-4-24 (Rhino 6, 6.4.18114.15591, Git hash:master @ 8151f20338e3e6414a1eba0c012953de62b87770)
Licence type: Commercial, build 2018-04-24
License details: Cloud Zoo. In use by: Sam Page ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: SAMWORKSTATION

GeForce GTX 780 Ti/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.13)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-27-2017
Driver Version: 23.21.13.8813
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 3 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Badger 1.0 (64-bit)\Badger.10.v60.x64.rhp “Badger”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”


(Pascal Golay) #4

Hi Sam - thanks - just to make sure:

The plane has a balck and white image applied at 50% and a green base color - if I understand what you’re seeing, the print preview and print would show the black and white but not the underlying green color, correct?

-Pascal


#5

Here is what I see:

And here is the print:
Print.pdf (2.4 MB)

Changing transparency back to 0% and color to 50% will yield the same result:


(John Brock) #8

@SamPage
Can you please send your aerial photo image?
I have a hunch that it is huge and potentially overrunning VRAM.
I’ve tried a bunch of different things here and I can’t get it to fail, but we don’t have your image file.


#9

It’s just a Google Maps grab:


(John Brock) #10

Rats.
It still works fine.
I assigned the rendering material to the Layer.

Here’s a screenshot with your image at 75% strength, color red, with 50% transparency.
Rendered display and the print preview are the same.

I’m running V6 SR4, on a Quadro P2000 with drivers from late January.


#11

Over here it will print correctly if printing from model space and I have it set to raster. It will not print correctly with either setting if printing in layout space. With layout printing, it doesn’t seem to matter if the surface with the image applied is in layout or model space, it will still ignore color / transparency (although in Layout space I have to setObjectDisplayMode to a rendered).

Sam


(John Brock) #12

OK, I’ll try that.
The surface is in the model and displayed through a Detail in the Layout?


(John Brock) #13

OK. Now we’re getting somewhere.
It seems to be related to SetObjectDisplayMode on the surface.

As a work-around don’t use that for now.

https://mcneel.myjetbrains.com/youtrack/issue/RH-45804


#14

Yes

I’m not sure it is though. If I just create a plane and assign the material to that, then change the detail to a rendered mode never using SetObjectDisplayMode, I still get the same not paying attention to transparency / color setting.

Sam


(John Brock) #15

That I can not duplicate.
On my two systems, the common denominator is using SetObjectDisplay mode.

We’ll see what the developers find.
I’ve linked this discussion to the bug report.