PrintDisplay and 'No Print' print width not working in Rhino 6 with Vray loaded

Draw a line, set its print width to ‘No Print’, toggle on PrintDisplay.

The line disappears for me in Rh5, shows normally in Rh6.

Can you reproduce this?

Hi Duncan - I can’t reproduce that here in RH6 for Windows.
Can you please run the Rhino SystemInfo command and post the result here?
-wim

Rhino 6 SR16 2019-7-9 (Rhino 6, 6.16.19190.07001, Git hash:master @ a8b4ee102e9e0eb1d11825df063e13f96d518f93)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 7-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.70

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-24-2019
Driver Version: 26.21.14.3170
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Thanks for that, Duncan. That looks fine - but you left the plug-in information out.
Is it behaving differently when you start Rhino in safe mode?
-wim

I cannot reproduce the error in safe mode in fact! Works fine there.

Rhino plugins
…\Commands.rhp “Commands” 6.16.19190.7001
…\rdk.rhp “Renderer Development Kit”
…\RPC.rhp “RPC”
…\AnimationTools.rhp “AnimationTools”
…\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\CreateQuadMesh (5bf6c0f3-3657-4ad5-834a-bbbb52706a40)\6.0.6950.16446\CreateQuadMesh.rhp “CreateQuadMesh” 6.0.6950.16446
…\RhinoRender.rhp “Rhino Render”
…\rdk_etoui.rhp “RDK_EtoUI” 6.16.19190.7001
…\rdk_ui.rhp “Renderer Development Kit UI”
…\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
…\NamedSnapshots.rhp “Snapshots”
…\RhinoCycles.rhp “RhinoCycles” 6.16.19190.7001
…\Toolbars\Toolbars.rhp “Toolbars” 6.16.19190.7001
…\3dxrhino.rhp “3Dconnexion 3D Mouse”
…\Program Files\Next Limit\Maxwell for Rhino\maxwell_rhino.rhp “Maxwell for Rhino” 4.2.6.2
…\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
…\BlockEdit.rhp “BlockEdit” 6.16.19190.7001
…\Displacement.rhp “Displacement”
…\NamedPositions.rhp “Named Position”

Thanks.
Could you try again in normal mode but with Maxwell and V-Ray disabled?
-wim

Hi Wim,

it is in fact V-Ray. Once the plugin is disabled, PrintDisplay works correctly.

I also just updated to V-Ray for Rhino v4.xxxx but the problem persists.

Is this a fix on V-Ray’s or Rhino’s side?

Hi Duncan - Thanks for that information!
This is something that would need to be fixed by Chaos Group.
CC: @Nikolay
-wim

Thanks.

The problem is identical for both Rh5 and 6 btw. Hope this can be addressed.

@Peter.Chaushev
Is there a chance a fix for this issue could be part of the next V-Ray Next update? Right now I am literally disabling the plugin, to then reopen Rhino, just so this native Rhino feature is working again.

Thanks in advance,
Duncan

Hello, Duncan,
The issue indeed occurs using Rhino 5 with V-Ray 3.60.03.
V-Ray 3, however, is no longer in development, thus I’m afraid we cannot offer a direct solution.
The issue is not reproducible with any subsequent V-Ray build (v4.00.01 or later).

Regards,
Peter

Well it is for me, and as the topic says, it’s about Rhino6. The Plugin-Manager reports V-Ray v4.10.01. Without V-Ray disabled, a “no print” on PrintPreview doesn’t work.

@DuncanW, apologies! I misread your comment from August.
We can set up a remote viewing session to provide direct assistance with this problem as it is not reproducible locally in our environment. If this is alright with you, please send a message to support@chaosgroup.com with a link to this forum thread.

Kind regards,
Peter