Print Width "No Print" should not hide whole object

… but just hide the outlines of a (poly)surface/mesh in any shaded display mode!
To actually hide an object, there’s ‘Hide’, or layer visibility.

This would open up possibilites to fine-tune a scene’s look (architectural plans/graphics in my case).

For example, in a floorplan or section layout, I would like to hide specific edges of 3d objects (In Revit, e.g., you can set the visibilty/thickness of any object edge specifically).

Since this is not possible in Rhino, as a workaround (or different approach), it could be achieved by setting the print width of the object to ‘no print’ (keeping the shading), then duplicating just the edges that should be visible.
Best regards

Hi Eugen,

I disagree.
First off, you are talking about the PrintDisplay here. Not a regular shaded display mode.
“No print”, is … well… no print. Not just no printing of specific features.

You can easily achieve what you want by making a few display modes where you vary the edge thickness of surfaces and then assign specific display modes to specific objects:



I agree with Wim.
No print means no print and any form of appearance would be confusing.

1 Like

Thanks, but I’m not fully convinced yet…
‘Print Width’ obviously regards the thickness of lines / sfr edges when printed, right? Not the whole object’s visibility (there’s a different way for that - Hide).
Set it to 2mm and you get lines/edges with 2mm. Set it to 1, you get 1. Set it to 0… oops, not possible, unfortunately.
Ok, there’s ‘No Print’, but that now hides the whole object. Not logical for me.

And yes, I’m specifically talking about what is printed (to PDF). Don’t care so much about what is displayed in the viewport. (My second screenshot is a Detail in a layout, with ‘PrintDisplay’ turned on.)

Anyway, I forgot that it’s possible to assign different view modes to different objects. Handy in fact, but does not help in that case.

What would be a way now to achieve what I want - set the line thickness of objects to 0 in print, but keep the shading (meaning these objects should occlude others, not disappear)?

Best regards

If I understand you correctly you can set the colour of printed object ‘by display’, make it hairline. and your object will not have dark outlines.

If you set the object’s display mode to rendered, it should not show edges by default. Otherwise create a custom shaded display mode with edge display turned off and assign the objects that display mode in the layout view.

Thanks, I’m trying, but the command SetObjectDisplayMode does not seem to list my new display mode…

Btw., the parameter which Display Mode an object uses should be listed in the object properties panel.
It can only be changed by the command SetObjectDisplayMode, but not read in the UI, right?

Checked ?

Thanks, but where is that?

Options>View>Display Modes>(Mode name)>Other Settings

Cheers, got it!
Now all of that is not particulary intuitive, is it. How about replacing it by something simple like being able to set the print width to 0? (if people insist on ‘No Print’ meaning ‘hide’, which I find counter-intuitive, too).
Anyway, I’ll go with this now, thanks everyone!

1 Like

“No print” doesn’t mean hide, it means that that layer or object is not going to appear in the layout you are generating. It is commonly used in layers that contain auxiliary lines or annotations that are only there to help in the process but without any intention of being printed.

For example, I always use a layer with “no print” for my details. That means that the outline of my details will not be printed, the content will be printed though. And that proves that no print is not the same as hide.

As others had pointed out, there are ways of doing what you are looking for, you just have to get used to the Rhino way.

1 Like

Still, ‘no print’ to my feeling should mean

  • in case of lines not to print them. That much is clear.
  • in case of surfaces, it’s OUTLINES, not the shaded object itself.
    You say it yourself - you set ‘no print’ for a Detail to hide it’s outlines(!), not the content.
    The exact same should be the case for shaded objects: hide the edges(=outlines), but keep the ‘content’, meaning the shaded faces in an analogy.

Also, even the parameter’s name ‘Print Width’ indicates it’s meant for lines, not surfaces themselves. Only lines can have a width.
The surfaces (or details) themselves are hidden with ‘Hide’ or layer visibility, then (including it’s outlines, too, of course).

That doesn’t make sense. We have given you ways to achieve what you want. I’m afraid you’re alone here.

Yes, I’m grateful, thanks! Will use that of course.
However, I’m trying to debate why this in my book is somewhat illogical. I cannot explain it better than in my last post.

Should your request be ever implement it would mess with many people’s workflow, mine included.

I get that…
A nice compromise could be to allow for a ‘Print Width’ of 0.
The value ‘No Print’ would remain as is - hide the whole object.

Hi Eugen - I see that this behaves differently for details and is therefore somewhat illogical. We can’t break a workflow that has existed for a long time but perhaps zero print width could be a compromise. I’ve put it on the list as RH-57048

1 Like

Wow, thanks a lot!
Would simplify certain workflows, I hope it’s now clear, why.
Best regards