Print a Flat file not working

Hi, since using R7 and now R8 i have tried to create this simple index page for a series of coloured tabs in an Eastlite folder.
I have not been able to get this to work. The Layout looks correct, been through all the settings, changing render modes etc, I can find, click on print nothing happens. The screen shot also shows the pre-print image not showing?
Many thanks

I thought i better upload the file so someone can see if its a self learning setting issue.
Front Page R8 copy.3dm (149.7 KB)

After no feed back, I have fiddled more with this print issue.
If i output to Rhino .PDF or image and fiddle with the page size (Bit of on and off to get it all to work) the display window shows up. Output to .PDF saves correctly printed. From there .PDF output to printer is normal. (Mac preview)

After energising this popup display window by using output to R.PDF i can then activate the output to a selected printer, all settings appear as normal, but nothing outputs to the printer or the printer queue as if it does not exist.
There is no screen message or indication either of whats happened.
I have 3 printers, all show up in the drop down menu, but none actually print.

Hello- I see problems here as well - no idea yet what is going on.


Thanks Pascal. There is a work around to .PDF in the mean time, so it is now useable. I expect eventually it will get sorted.

Hi @JP13
Thanks for the file.
Is this what you are looking for?

Front Page R8 raster.pdf (521.7 KB)
Front Page R8 Mac.pdf (521.7 KB)

There have been a lot of issues fixed in Rhino sr4 and sr5 WIP.
Do you have the release candiate?

It will not become easily available as the release candidate until February 6.
However, if you want to try the WIP, email us at and we will get you a link.
The WIPs are really easy to use on the Mac, you just pick “Keep both” when installing the disk image.
Windows is not that easy.

Mary Ann Fugier

Hi Mary Ann. Yes those outputs is what i need. I can create the .PDF from R8 and then print that file, both Raster and Vector appear to work.
I have setup the release candidate update, i am on version 8.8.4.
I’ll send an email for the link, try that and see how it goes.
Many thanks. John-Paul

1 Like

While you are looking at this print issue another small thing i have noticed is that the scaled to fit shows up in inches, where as best i can tell my systems is all in metric. I don’t think this is causing an issue with the scaling, I just though inches would not show up in a metric system.
Many thanks.
Box shows output to R.PDF.

I just want to add that I am having a similar issue. If I choose my printer, I have a blank print preview.

I can choose Rhino PDF to export. The print preview does fill with an image and then I can print the file from other software .

The print preview remains filled if I switch back to my printer from Rhino PDF, but changes to the print settings do not show up in the print preview and it still does not print directly from Rhino.

Mac M2 Mini, Mac OS 14.2.1
Rhino ver. 8.3.24009.15002
Brother Laser printer

All are up to date with newest software.

Hi @Ukktor,

Rhino 8 sr4 is the release candidate.
There have been a lot of issue fixes so it is best to have you try Sr4.

You can download the release candidate by changing your update frequency to Release candidate in Rhino 8 → Settings → General.
Check for updates and install.

Let us know if this solves the blank page for you.

If not email, attention Mary and we can get you a link to the sr5 WIP.
It is really easy to test on the Mac, because you can “keep both”.

Thanks for your help.
Mary Ann Fugier

The SR update to 8.8.4 did not fix it. I will send you an email. Thanks for your help. Had no issues with this until v8. Rhino v7 worked fine and still does work fine.

Hi @Ukktor
I have logged:
I have logged with a customer file, so it is open for public view.
This ia Mac only issue.
I have not been able to reproduce on Windows.

As a workaround:

  • Print with RhinoPDF to a PDF.
  • View and Print from your PDF viewer of choice.

We will let you know when there is fix to test.
But currently this is an open issue.

Thanks for your help reporting and testing it.
It was a bit illusive for a while.

Mary Ann Fugier

Thank you for the reply. I’m looking forward to being able to test any fix you develop.


RH-79723 is fixed in Rhino 8 Service Release 4 Release Candidate

A post was split to a new topic: Print color issue