Possible Rhino Memory Leak?

I’ve been using Rhino 7 for a while now for Uni and every so often it will suddenly freeze my whole computer before closing itself. After this point whenever I open Rhino again it’s really laggy and can close itself at any point again unless I restart my whole PC. I saw a thread from a while ago saying it was because Rhino only allows for one CPU core to be in use but after checking that it doesn’t seem to be the case, however when I checked my memory, the MHz seems to fully max out, which is exactly what happened when I encountered a memory leak with another software. The size of the files don’t seem to affect the issue, as I’ve encountered it with files under the size of 1mb. I am unsure what causes it, but I provided a video of what happens here if it’s any use: Rhino Memory Leak? - YouTube

As for my PC specs, they are as follows: CPU: Ryzen 9 3900x, GPU: RTX 3060, RAM: 2x Corsair Vengeance LPX 16gb, 2x Corsair Vengeance RGB PRO 16gb. The only plugin I use is Enscape, but it isn’t usually running whenever this problem occurs.

If anyone could help me out with this issue it would be greatly appreciated. I have lost upwards of half an hours worth of work to this which isn’t much but the fact that it happens every second or third time I use Rhino is super annoying.

If you could start by posting the text result from the Rhino command _SystemInfo

Yep, here it is:
Rhino 7 SR16 2022-3-8 (Rhino 7, 7.16.22067.13001, Git hash:master @ aa7902c94c5aa33511e60d30f82b636be43bc85f)
License type: Educational, build 2022-03-08
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 (NVidia) Memory: 12GB, Driver date: 12-8-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.88
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-8-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\Users\Apple Of Doom\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.21250.810

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

So I had a chance to look at your video on a large screen - on my phone I couldn’t see the text in any application.

The numbers you are looking at are the clocking frequencies and are not interesting or related to memory leaks. You need to look at the memory consumption using the Task Manager of Windows. Here you’ll find whether your RAM fills up or not.

Your SystemInfo looks good, I’d update to the latest Service Release 7.18 to get the latest fixes and see if that helps any.

Ok the issue happened again however there doesn’t seem to be anything strange occurring.

Once again this caused my whole computer to freeze for around 30 seconds before Rhino went completely blank and closing on its own with no windows error message popping up or anything. I have no clue what could be causing it.

Can you update your video driver? Then if that doesn’t clear it up please disable Enscape and try again. Thanks.

Is there a chance that all the information stacked for the Undo operation can affect the system memory? I had several cases where going back to 50-100 Undo steps basically freezes my PC and sometimes crashes Rhino. It’s especially evident while doing a 1-2-3 Undo steps after previously moving or rotating a 3d scan data consisting more than 1 million polygons. My Rhino 7 SRC18 crashed yesterday after a single Undo step for a 308MB file consisting 3 laser scan models. I have 16 GB of RAM. Is the Undo information stored in the RAM or the system hard drive/SSD?

I just checked and it says my video drivers say they’re up to date. I just restarted my PC, so I’ll disable Enscape and see if that helps.

There are 4.26.22 game ready drivers GeForce Game Ready Driver | 512.59 | Windows 10 64-bit, Windows 11 | NVIDIA

as well as studio drivers for available for that model

Were you doing anything with Enscape? The most likely issue after updating your video drivers is Enscape, either a bug, or those GPU renderers can have extreme memory requirements, like you might need 12GB of available virtual memory–not RAM, virtual memory, this is an issue I had with iRay once–to match your video card.

Long shot this, but as you have two different memory card models, check with your motherboard manual that they are in the correct slots so that each type is paired and not mixed. Your manual will show which slots are paired.

If that isn’t an issue you might try removing one type of memory at a time to see if that helps.


1 Like

After installing the drivers I haven’t seem to run into any issues at all. The issue is kind of inconsistent so if I run into it again I’ll continue the thread. Thanks for sending the link!

One thing is, never believe Windows about this - just check the nVidia (or whatever) website for the latest.
I’m glad it is working now.