Polyhedra naked edges

I have been working with polyhedra for years. Now, suddenly, my models have naked edges.
icosa with naked edges
instead of this:
icosa repaired
Why is this happening?

A guess is surface normals may be flipped.

Upload a .3dm file with an example of the problem and you are likely to get more help. Drag the file to where you type a post or click on the vertical arrow icon above where you type a post.

Other people are already trying to help me, but since you asked, I’m attaching an example of the file.
By the way, this one does not have naked edges, but if I Check Mesh, this is what I get:
This is a bad mesh.

Here is what is wrong with this mesh:

Important things to consider with this mesh:
Mesh has 12 faces with directions different from the mesh as a whole.
12 bad.3dm (34.8 KB)

UnifyMeshNormals will reset the mesh normals so they all face the same way. If the mesh is closed all normals will face outward.

Right. This looks more like something has changed relative to how mesh facet normals are displayed.

These are not naked edges.
These are individual mesh facets with their normals flipped wrong side to.

One work around could be changing the Shaded working display mode so both sides of the mesh facets appear the same.
My guess is your display mode has backfaces set to be culled from the display. The default setting is for backfaces to display the same as front.

Are you set to cull?
If so change the setting or click the big Restore Defaults button at the bottom.

Any luck?

The first setting to Cull backfaces did not solve the problem.
Clicking the Restore Defaults DID solve the problem. The funny thing is that I had tried Restore Defaults several times with no success.

I applied the Restore Defaults to the model I was working on, and it solved the problem.
But when I started a new model, a simple dodecahedron, it came with the same problem. Neither set to Cull backfaces nor Restore Defaults solved the problem.
Mesh repair worked.

So far, I am unable to repeat the problem you’re seeing with Polyhedra.
I’ve tried a variety of shapes and have set my Shaded display to cull back faces to see it and still no problems.

I am in Rhino V7, using the current version of RhinoPolyhedra from Food4Rhino.

Are you running anything different?

I’ve also tried both Small Objects - Millimeters and Small Objects - Centimeters.

After you solve why the back faces are not showing, it is still good practice to have all the normals of a mesh facing the same way. If they face different ways other problems can arise.

I’m in Rhino V6, and I don’t have plans to upgrade in the near future. Still it is a mystery that this started to happen to me (alone) lately, and that during years I had no problem.

I understand. It is just cumbersome to have to be repairing the models every time the problem arises.

I’ll load up the older version of RhinoPolyhedra into V6 and see if I can reproduce the problem.

Running UnifyMeshNormals proactively on your models should not be cumbersome. If the meshes do not have a huge number of faces the command should execute quickly.

@georod99 How are you generating the polyhedra? Are you using the RhinoPolyhedra plug-in?


I can confirm that the older V6 version of RhinoPolyhedra results in some flipped normals in the dodecahedron shape.
I needed to run UnifyMeshNormals to sort it.

This has been fixed for the V7 version of the plug-in.


I installed it and seems to be working. Thanks one thousand.

I installed the RhinoPolyhedra plug-in and seems to be working OK. Thanks one million.