Rhino viewport rendering bug in shaded / x-ray / ghosted mode

I created a simple(-ish) shape (mesh) using the Polyhedron command from the Polyhedra plug-in. The solid shows correctly in wireframe view and it also renders correctly in Rhino Render and in Flamingo nXt 5.5. However, when I switch the viewport to shaded / ghosted / x-ray mode, the shape is drawn incorrectly - parts of the faces are missing, depending on camera angle (changes as the view is rotated around).

If I explode the mesh, all faces show correctly, but re-joining them causes the same issue again. When I use “Select bad objects”, the mesh is not selected.

This is in Rhino 6, version SR27 (6.27.20176.5001, 2020/06/24). I attached the file that exhibits the problem - is this a Rhino bug or an issue with the plug-in? And is there some workaround to get it working right?

Tree_Leaves_01.3dm (207.2 KB)

That seems like a bug in the plugin, if you run UnifyMeshNormals it’s fine. It renders fine because your renderers render objects as double-sided by default. The OpenGl working views don’t, the “inside” mesh faces of a closed solid are not drawn…and the “normals” are a bit random so what’s “inside” is unclear.

Hi Gyorgy -
I’m not seeing that here with the Rhino 7 version of that plug-in, so that issue might have been fixed.
To be sure, though, which polyhedron did you import and what settings did you use?

@JimCarruthers and @wim

Thank you for the responses - I tried UnifyMeshNormals and that fixed the problem.

I used the “Bigyrate Diminished Rhombicosidodecahedron 55 vertices / 52 faces” solid. The Rhino 6 version of the plugin doesn’t have settings (at least I never stumbled upon them) - I just selected the shape from the dropdown and then scaled to the size I wanted.

Hi Gyorgy -

You might be running an older version of that plug-in, then. I just tested the 6.0.6863.15197 version that is on Food4Rhino and there is an option to create meshes, surfaces, or curves, and an option to colorize or not.

In this version, if you pick mesh and colorize, you will still get flipped normals on some faces but not faces that are not rendering at all as you showed in the file that you attached. I’ve created item RH-59332 for the developer to take a look.

Hi @gyorgy.bozoki,

If you use the Colorize=Yes option when making a mesh, then the output it a group of mesh faces, not a single, closed mesh. This is because meshes don’t support per-face colors. This is why normals are not unified.

– Dale

@dale and @wim Thank you for the responses - I double-checked and I’m using 6.0.6863.15197 and I found the options after you mentioned it. I thought they’d show up on the dialog but I see now that they appear as parameters on the command-line when the center point is selected.

I was using default options (I didn’t change anything as I was trying to draw shapes so Colorize was No (Mesh also seems to be the default).

It’s a very cool plugin, thank you for making it. Now that I understand how to fix the shape in the view, it’s not a big deal.

Thanks for the feedback, Gyorgy!
Dale fixed the issue with the flipped normals on the mesh versions and I’m sure an updated version will be available for download at some point.

If you are using the Rhino WIP, just use the new PackageManager command to get the latest version.

– Dale