PointClouds display problem

Hi @stevebaer, @jeff,

i have a pointcloud with normals which displays shaded fine in V5, but in V6 (6.14.19118.15561, 28.04.2019) i get no shading in Shaded display mode. The driver vor Radeon HD7970 is not too old:

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 3-26-2019
Driver Version: 25.20.15031.1000

I have shade vertex colors enabled in my Shaded display mode, same settings as in V5:

Is there something broken ?

_
c.

That would be my first guesstimate…

Just so that we’re looking at the same thing…please post a pointcloud you’re working with and I’ll take a look.

Thanks,
-Jeff

Hi @jeff,

below is a spherical cloud which displays the normals fine in V5 but not V6. I have checked all possible “Color & Material usage” settings but unfortunately this fails in V6.

Sphere.3dm (771.9 KB)

_
c.

Thanks.

Yep…this looks busted… TestPointCloudStyle seems to see the normals, so they’re obviously there…My guess is that when I worked on the styles code, I busted the standard mode …doh!

Sorry… I’ll dig into this more in a bit and see what’s busted and why.

-Jeff

Thanks @jeff,

i am glad you where able to reproduce this. Meanwhile i found a few more issues, compared to V5:

When i navigate in the viewport, V6 seems to hide some of the point cloud points and shows the full cloud again when navigation stops. Is there a way to disable that ? (I would prefer to see the full cloud always, even if my frame rate drops a bit).

btw. when the normals are working again, could you please check that they still show properly when “Shade highlight selected” is enabled. I remember in V5, this never worked properly causing that the shading was shown only halfway and the rest of the cloud was shown in black…

_
c.