Point of intersection of two surface is not on a surface

Hello All,
I made a surface using “devloft” command and try to trim another extruded surface with the original surface. Unfortunately, the trim is not happening on the original surface, it is leaving some of the trimmed surfaces after the original surface. I have attached the sample file. Basically, I am trying to trim the small surface with respect to the big surface. Could you please help me to find a way so that the surfaces trimmed exactly at the original surface. Thank you.

Sample.3dm (43.5 KB)

I think you’re confusing a poorly fitting render mesh and thinking the surfaces don’t match.

If you run the Intersect command between the two surfaces, you’ll get a curve that matches the foot of the smaller surface.
You can also change the Mesh settings in Options > Mesh to Smooth and slower. You’ll see what looks like the overlap get a lot smaller.

Thanks John,it cleared my confusion.