Intersect command strange behaviour

Good Afternoon,

I’ve noticed a problem with the Intersect command, which I would like to bring to your attention:

I tried using the Intersect command to get the intersection point between the curve and the surface.
Then I tried achieving it by other means:
  1. Moving the curve
  2. Trimming the surface
  3. Changing the curve

Unfortunately, none of these methods worked. In the end, I managed to get the intersection point by changing the surface.
Another thing that seems to work is shrinking the trimmed surface.

I’d like to ask what is the reason behind this strange behaviour.
Kind Regards,

Curve-Surface.3dm (52.8 KB)

You are more likely to receive assistance if you provide a file with curve and the surface which is not intersecting. Do no expect someone else to go through all the steps based on the video to create the surface which causes the problems.

Hi @davidcockey, thank you for your attention. you only need to extrude the curve in the negative Z-direction, anyway here is the file with the surface:
Curve-Surface.3dm (40.7 KB)

Hello - for now, if you ShrinkTrimmedSrf the surface, you can get the intersection point. My guess of the moment is that having the underlying surface and the curve entirely coincident is problematic for the intersector.


1 Like

Hi, @pascal, Thank you for your answer, yes I’ve mentioned that Shrinking the trimmed surface seems to work. However, I wanted to know if it’s the expected behaviour of Intersect or am I misunderstanding something?

It seems even changing the curve to make this coincident partially couldn’t help to solve the problem.