Point deviation

Hello Pascal,

good to know you see problems as well :slight_smile:

Now I tried again, and see some statistics.
Don’t know what I have done in another way today.
But look how the panel looks like:

I only clicked 1x on the panel tab (as it did not come to front).
BTW, again you see the decimal separator issue and more.

Sometimes, or more exact: 1x only.
When I change a number, the result is refreshed 1x, and on next changes nothing happens.

Today I see numbers as well.
But again, sometimes not.

No action.
But when I move the surface.
It would be good if it would work for both operator sets, this is quite handy.

I now see the analysis result is not correct.
The mesh and the srf are > 3mm apart.
Shouldn’t I see some red results?
From the colors, the difference is not > ~0.5.
Also from the numbers.
Look:


CP_Analysis_Deviation.3dm (421.3 KB)

Hi Charles - yeah, I do see red here at your settings - I am not sure what is going on… I do see some more weird drawing in the panel itself.
https://mcneel.myjetbrains.com/youtrack/issue/RH-39318
I think this is what you expect, correct?

Hm, I also see that you are allowed to select the same mesh for both inputs… all points blue!
https://mcneel.myjetbrains.com/youtrack/issue/RH-39319

https://mcneel.myjetbrains.com/youtrack/issue/RH-39320

-Pascal

@pascal,

i tried to use _PointDeviation with a mesh for the pointset and really would like to express my wish to have a way to disable the automatic update of the command. My mesh has 600K polygons, if i start _PointDeviation it takes 2 minutes before the dialog comes up.

It opens with some default values which, of course, need adjustment. To see what i want, i first have to disable “hair” display which obscures the view. After waiting another 2 minutes i can start entering my values for “Good point”, “Bad point” and “Ignore”. Between each edit i have to wait 2 minutes as it likes to update automatically. In case of entering decimal values in the fields, it starts the calculation even when i entered the first numer of eg 0.5. I do not see anything useful that i get an update of the deviation display once i entered zero and again after i entered a decimal point.

To get my preview with the required values it took almost 10 minutes of waiting. Please disable automatic calculation and hair display by default and provide a checkbox to enable automatic display, along with the “Apply” button used in V5. Otherwise this command is really impossible to use with large pointsets or meshes.

Btw. when pressing the button “End”, it hangs for another 2 minutes until i can get back to Rhino. This seems to be a bug.

c.

Hi Clement - re you using a single surface and a 600k mesh or is it a brep? If you can send me the thing, that would be great, I just chatted with the developer and he’s like to get some specifics so he can understand what’s expected and look for where the hang-up is.

I guess one key question is, does the same file behave better in V5 (like, the time for the initial dialog display, or the time it takes to update on Apply) I gather it does, from your comments, but just checking…

thanks,

-Pascal

Hi Pascal, it happens with both, single surfaces or breps. I’ve found that if i just try to close the dialog instead of pressing the End button, it hangs too for a while. The mesh i’m testing with is the compressor mesh linked by @wim in this thread. If you import it into below file using “Map obj Y to Z”, you might have something to test.

It seems that the displayed colors for the points are wrong as well, i’ll include a screenshot with the values i used.

Test.zip (1.0 MB)

c.

Hi Clement - thanks, I do see this - definitely not useful.

https://mcneel.myjetbrains.com/youtrack/issue/RH-39352

-Pascal

1 Like

@pascal,

another small issue using Point deviation command which might be easy to solve: Once a mesh has been selected (in case of a pointset), it remains selected when the command asks to select surfaces to test against. Would it be possible to not keep the PointSet (in my case the mesh) selected when it asks for the objects to test against ?

Imho it is pretty hard to find any object while a dense yellow mesh wireframe obscures everything…

btw. in the current WIP, the command hangs indefinitely using my test scene from above once i entered a decimal value for “Bad Point”.

c.

Hi Clement - Tim is looking into the lag… it is pretty bad, I agree. The selection part is also ‘on the table’ -here, as of my build of the moment, the initial selection is un-highlighted when the prompt comes for the other objects -what you want, I think.I am not sure that de-selection will persist in the next build - due to some other considerations - mainly, making it impossible to select the same thing for both inputs… this can be painful if the objects overlap closely, even though it has some potential utility.

-Pascal

Hi Pascal, ok i will try it in the next built.

c.

@Pascal
Hi Pascal,
in this release (6.0.17164.11481, 13.06.2017), the panel doesn’t show up at all.

See this thread:

RH-39352 is fixed in the latest WIP

RH-39320 is fixed in the latest WIP

@pascal, there are still issues with _PointDeviation. If i try to change any of the numbers in the fields it wants to update immediately. With a large mesh the command is unusable as it always opens with the wrong default values and every field has to be changed.

I’ve just tried it and wanted to change a field value from 1 to 0.5. After i’ve entered “0.” it updates, rhino goes to “not responding” and once it was ready it shows 1 in the numeric field. I am testing a mesh with 700K points against a single surface. After any value change, i get a timeout of 30-40 seconds, then Rhino goes out of the “not responding” mode and the dialog vanishes. If i hoover my mouse over the tab of the properties dialog, the _PointDeviation dialog comes back.

Please bring back the “Apply” button used in V5 or allow us to disable the automatic update feature of the command.

_
c.

1 Like

This is how it behaves, i am sorry for the most boring gif animation on earth:

_
c.

Right, no cats. I’ll check this, thanks.

@clement - do you have a surface against part of a very dense mesh here? that is what I am testing (mesh = 2.4 million faces) and there is no lag at all in the dialog so far - there must be another component to this that I am missing.

-Pascal

Yes, a single surface an the mesh has 750K faces. I can repeat it with every large mesh.

Are you testing on Win7 or Win10 ?

_
c.

Hi Clement - Windows 10 here. I’ll find someone running 7.

-Pascal

Hi Pascal, what happens if you enter a comma as decimal seperator ? I can repeat that timeout problem here using that instead of a dot.

Edit, that’s not it, with a dot it also happens…

_
c.