Please help if possible

Hi All, Ive used rhino 3 and rhino 4 and have now moved onto rhino 5.
A small issue I have is in the display of simple items.
in the sample below you can see that I started with a simple cylinder and a surface to use as a bolean tool.

the view
during bolean you can again see clearly the result of what your bolean options will be

once you bolean the two items the view changes to make it much more difficult to view cleanly.

this then becomes the default view - making it difficult to view.
does anyone know why this happens of if its possible to stop this happening ?

I see this. You appear to be using Boolean2Objects with a cylinder that has isocurves showing and a surface that does not. It is the isocurves that actually outline the cylinder edges in the Top view, there are no surface edges to see (the seam line is either up or down).

If the first object you pick (mouse pick, not window) in a Boolean operation does not have isocurves showing, the result will not have isocurves either. That is to say, the result of a Boolean operation takes on the characteristics of the first object picked - layer, color, isocurve density, etc… This is actually consistent with Rhino’s behavior across all Boolean operations. With Boolean2Objects, if you pick the cylinder first, you should see the isocurves in Top view.


In addition to what Mitch said; you can turn on the display of the isocurves for an object in the proporties panel when that object is selected.

thank you both for your answers. ive been using rhino for 10 years and it just shows how much I still have to learn :laughing:
Mitch - when I test this I get the resulting view

which I find super interesting. why does it not complete the view eg mirror that edge on both sides.
do you know why this happens (I also tested this changing the single cutting surface into a “solid”
, rather than just a surface with the same results.

Wim - thanks heaps as well. you’ve taught me another new trick which I’m very thankful for.

on the above image once I turn “show surface isocurve” to visible I get this view

which is perfect for me working , but (don’t you hate that word), as you can see it shows one side lighter than the other. do you have any idea why this happens ?

thank you both for your help.
best regards

The darker curves are edges and seams. Seams are where a surface such as a cylinder is “closed”.

thanks David, I appreciate all help.
my question though would still be why are both “sides” in this image not showing up the same.
it started out as a true cylinder and is cut by a surface that is exactly the same on both sides - therefore in my head the image should be exactly the same on both sides (but as you can see it is not - in either examples).
so edges and seams should appear exactly the same on both sides (the left and right)

There is a difference between surface edges and isocurves.

Edges are intrinsic parts of a surface object in the sense that they explicitly define its borders. Surfaces can have “naked” (open) edges, “manifold” edges (joined to one other surface), or “seam” edges (joined to itself as in a cylinder) in any combination.

Isocurves are more or less artificial in the sense that they represent the NURBS curve that defines the surface in one direction at some arbitrary point along the surface. There are an infinite number of possible isocurves in either direction. By default, with isocurve density set to 1, Rhino shows you the “middle” isocurve of a surface. There are however a few “special cases” such as a cylinder or a sphere - you get 3 plus the seam, in order to better show the object in wireframe. You can turn off isocurves if you like or increase their density.

Isocurves do not however represent visible tangent edges of something like a cylinder as you might expect. Tangent edges that do not coincide with visible seams or isocurves are not shown at all in Rhino wireframe display modes.

Note also that Rhino 5 has a new type of object, called an extrusion object. The creation of extrusion objects is on by default in Rhino 5 and a number of the familiar primitives that were polysurfaces in Rhino 4 are extrusions in Rhino 5, including boxes and cylinders. Extrusion objects may have different isocurves than their polysurface equivalents, and they have none at all in the extrusion direction.

Below is a sphere and a cylinder surface in wireframe with isocurves set to 1 versus turned off. Note the sphere is no longer represented by anything but an arc (the seam edge) when isocurves are off.

I hope some of this explains what you’re seeing here…


well… By default, the isocurves are drawn at the knot locations. The special case would be a simple plane where they are drawn in the middle of the surface. More here.

sure does Mitch.
Thank you all for your help. Its been enlightening and also a little humbling.

Ooops, yeah, I knew that - once upon a time, long, long ago and far far away… :confounded:
It’s just been so long since I’ve had to do much of anything that didn’t have degree 1 surfaces…

Sorry for the dis-information and thanks for the correction @wim !


1 Like