Planar bug in Rhino 5 SR4?


#1

Context: Planar turned on and creating a Control Point Curve, using typed in co-ordinates. (with Grid Snap on and Osnap off)

If I create the Start of Curve while the Right viewpane has focus, then continue by creating the remaining control points while the Top viewpane has focus, the result is a non-planar curve, the same as I get with Planar off.

However, if I create a Start of Curve in the Top viewpane and continue in the Right viewpane the result is planar. Similarly, if I click in the viewpanes instead of typing in co-ordinates, I get a planar curves in both scenarios. As the behaviour is inconsistent I believe I have found a bug.

Apologies from a forum newbie if this isn’t the place for bugs to be raised.


(Brian James) #2

Hi Constructor,

This is indeed the place for bug reports, wishes, gripes etc.

Thanks for this report, both scenarios stay planar in SR5 here which is still a release candidate I believe. You should be able to use this build too if you change your settings in Options>Rhino Options>Updates and Statistics after switching to ‘release candidates’. If you still see this after that update has downloaded and installed, I must be missing something and please let me know.


#3

Hi BrianJ

I have downloaded the 5.5 service release and I still experience the bug when typing co-ordinates into the command line. It works ok when I click in the viewports to place the control points.

I will email you a 3dm file to illustrate what I mean.

(Incidentally, ignore the part of my original post which says “if I create a Start of Curve in the Top viewpane and continue in the Right viewpane the result is planar” - having revisited, it is NOT planar).


(Pascal Golay) #5

Hi Constructor- to attach a file, click on the image icon (7th from the left) in the reply area - it allows 3dm files to be added as well as images.

-Pascal


#6

Here’s the file: PlanarBug.3dm


#7

Thanks Pascal - would be great if that helpful advice could be pinned at the top of the forum.


(Brian James) #8

Hi Constructor,

Thanks for the file and further explanation. If you type “r10,10 enter” the “r” will make the coordinate relative to the first point placed in the top view. Whether or not the coordinate input should remain planar without the relative notation is possibly a bug though and I’ll file it to see what development says. Thanks again for the report.


(Margaret Becker) #9

Done.