"Pixelated" STL export?


#1

I’ve exported hundreds of different types of file to STL, and never encountered this problem. Now lately I’ve been creating stepped contours at work for cutting on a CNC, and every now and then ill get this problem. I’ve only ever seen it happen on these contour maps. I’ve tried rebuilding all the curves, drawing over them, and many other things. The original file I create has no openings, no naked edges or non-manifold edges… all the curves are within tolerance… I cant figure out what could be causing this. Any ideas? Top picture is the original rhino solid i created, bottom two are the exported STL.


(John Brock) #2

You clipped off your images and aren’t showing your coordinates.
Without a real file, I’m guessing, but it could be your objects are too far from the origin.
STL files are only single precision meshes and have to sty pretty close to the World 0,0,0 coordinate origin.

If your model is a long way from the origin, Move it close to the origin, run ClearAllMeshes, then see if you can make a good STL file.


#3

Excellent! The image was clipped for kb size, but the drawing was about a mile away from the origin. Moved it in and bam! worked like a charm. Thanks! Te topos ive done often get away from the origin doe to scaling something that is much larger than our final output… so it all kinda makes sense. Thanks again