Pipe failure

In the attached file I need to pipe the curves to a radius of .4mm. Green curve works as expected, red curve fails. Why? How to fix red curve?

TIA
robb

PipeFail.3dm (518.1 KB)

If you run the command CrvSeam and move the seam to the marked position, then the Pipe command works:

// Rolf

That fixes it. I wonder what the difference is…

Thanks a bunch.
Robb

I wonder too, I simply have no idea. From the perspective of not knowing the fact, it seems to me to be just the typical thing with algorithms, which sometimes doesn’t handle all preconditions, and therefore I tried to move the Seam and… well, there it was.

Someone else, with deeper knowledge in the dark side of Rhino curves, can explain this case in more meaningful terms. :face_with_monocle:

// Rolf

Hi Robb - my guess is it has to do with direction - flipping the curve also allows Pipe to work – it seems that figuring out that miter works better if coming at it from that middle arc. I’ll add this to the heap.

-Pascal

1 Like

Hi Robb, can you share how each curve was made, please? TIA

I’m doing a lot of work making patterns these days. These 2 curves are part of a pattern that uses many of the same curve. I start with one clean curve on a flat surface at 0 on the Z axis. I copy and array that one curve to achieve the pattern I am looking for. I then flow those curves onto a complex 3D surface. In this case, more that half worked perfectly. The failure was identical on the number that failed. There was nothing about the pattern of failures that I could trace to the copy and array process.

I hope that helps.

Robb

1 Like

I just reviewed the direction of the curves in my full model. Direction was identical in all curves on my 2D map. Once to the 3D surface, the failures had the start point moved to the other corner. No explanation I can fathom.

Robb

Hi Robb - what do the target surface directions look like? Are the curves flowed to a mirrored copy for instance?

-Pascal

The base surface and target surface are untrimmed with direction carefully mapped to be the same. There is mirroring involved the the 2D pattern layout but that seems to not be the culprit here. I can upload the two surfaces and curves if you like. Just can’t be in public.

Robb

Hi Robb - I don’t think anything has gone wrong other than in Pipe.
https://mcneel.myjetbrains.com/youtrack/issue/RH-57269

-Pascal