Persistent BREP to Domain Conversion problem in Rhino 8

I have a Grasshopper model that worked well with 6 and 7 but in Rhino 8 my “Divide Domain” object remains red with the error “the data conversion from Brep to Domain failed” Same error with the Twisted Box object, “the data conversion from Brtep to Surface failed”.

I’m running Rhino 8 on a MacBook Pro M3 Max with 64GB of Unified Memory and macOS Sonoma 14.4.1


Internalize the data and send in the component causing the trouble? We can take a look.

The error messages make sense. But what is expected in those cases?

I can send you the grasshopper file
ODIS KI 10 (27.2 KB)

See attached

Its work we are conducting with traditional Native American Dwellings in the Southwestern part of the US. The number of vertical dome ribs and the number of horizontal bands have very specific cultural meaning - ideal for parametric design.


Hi Phil -

This fails here in Rhino 7 as well.
In Rhino 6, the Sweep2 component outputs an untrimmed surface. In Rhino 7 and 8, this results in an open Brep that can be exploded into 4 untrimmed surfaces.

The Divide Domain2 component can convert an untrimmed surface into a domain, but can’t do that with a polysurface.

Perhaps a work-around can be to use Rail Revolution instead of Sweep2? That outputs an untrimmed surface but results in a slightly different surface…

Thank you!!! I’ll give that a try today and let you know. Pilot error on my part and not a bug. Good to know!