Penguin doesn't load up correctly


#1

I am using the trial version and I was seriously considering buying this…

However the first problem is that ‘Penguin’ does not appear in the list of available renderers after I close rhino (5).

So after installing “Penguin20_Release EVAL_SR4_x64.msi” it only seems to work after loading Rhino the very first time. After that it just disappears every time I load Rhino.


#2

@rbarcena ¿Hola?


(Rodrigo Bárcena) #3

Hi @LeslieDeanBrown,

Are you doing both actions (installing and running Rhino for the first time after installation) within an Admin account?
When running Rhino, instead of double clicking on the shortcut, right click and select run as admin.

ps. sorry for the delay, @rbarcena is not my username here, the mention didn’t work… and 5 days ago I was on holiday, just came back.


#4

No problem about the delayed response @Rodri
Hope you had a nice break. :slight_smile:

Okay, it took me a little while, it eventually worked; I tried the following:

Uninstall penguin.
I don’t have the option to right-click run as administrator on msi files.

So I tried the following
Reinstall penguin 2.0 using the following in the command line:

msiexec /i c:\Users*deleted*\Downloads\penguin\Penguin.msi

[renamed to penguin.msi, to save myself typing “Penguin20_Release EVAL_SR4_x64.msi” in the command line, because I already know copy/paste often doesn’t work there. But that shouldn’t have changed anything…:confused:]
deleted for a bit more secuirty over the net.

Before that I also tried

msiexec /a c:\Users*deleted*\Downloads\penguin\Penguin.msi

Delete only the penguin entries in registry.

Uninstalled Rhino.
Reinstalled Rhino 5 using right-click “run as administror”.
Running “Rhinoceros 5 (64-bit)” as administrator.
That is a shortcut on desktop, so I also tried running “Rhino.exe” as administrator.
No luck there.

Penguin installs to:
C:\Program Files\Penguin 2.0

At least I found out it does load Rhinoceros 5 (64-bit) if I run "Penguin.rhp"
But it won’t stay there the next time I run rhino.

Penguin does work on my laptop with Rhino 5, and stay put, but I never use rhino on my laptop as it’s a 13" 1920x1080p screen compated to a 27" 5120x2880. No comparison. It’s just there as a backup in case my main computer completely fails.

At least I have solved another problem I was having, which is that FlamingoNXT (kept appearing as a plugin even though that was uninstalled many times over)

Finally! I think it was just a case of enabling the penguin selecting the plugin checkbox in the rhino > options > plugins
I should have checked this first. .:blush:


(Rodrigo Bárcena) #5

… I was assuming you had already tried that, my bad!
glad you got it working!


#6

No worries.

I still have some other questions though, so I will start new thread(s) because it is two separate issues…