Penguin 2.0 SR5 Unresponsive to installation settings


(Basti86) #1

Penguin 2.0 SR5 will not respond to uninstalling or repairing using the .msi file. Rhino 3D v6 does not display Penguin as a rendering engine, and does not show up in the Rhino applications license settings. BUT the online login to the Rhino 3D website [My Account] shows the Penguin rendering engine licence as active.

How can I restore or re-install Penguin so that Rhino will recognize it as a plug-in rendering engine?
OR completely remove Penguin from my system in an attempt to start a clean installation.


(Philip Dlcruz) #3

I have the same problem as @Basti86.

I have the same issue on my desktop. It had Rhino 5 before with Penguin as one of the plug-ins. Then, when I uninstalled Rhino 5 and all its related plug-ins, Penguin won’t uninstall. I have tried restarting my computer and uninstalling Penguin again, it still won’t uninstall.

I then just proceeded to install Rhino 6 and reinstall Penguin, but Penguin is not recognized on Rhino 6 when I run it.


(Basti86) #4

Hey Philip sorry for the late reply. Im not too sure what the cause is either, seems like there are files in the background that need to be removed before reinstalling. very annoying. have you had any luck lately?


(Philip Dlcruz) #5

Hello @basti86

No, I had no luck at all. I have tried looking for the Penguin folder in Program Files, deleting it, then installing again - did not work. I also tried modifying the install location - did not work.

I do not know how to solve the problem or if there is anything I should have done differently.

But, when I tried an install in my laptop that has never been installed with Rhino or its related programs, everything worked fine, Penguin was there and can be used with Rhino 6.


(Xavier Civit) #6

Hello @basti86,

In spite of Penguin being uninstalled correctly, the license is still taken from the cloud zoo when Rhino opens. The problem has been reported to the cloud zoo team.

Xavi


(Xavier Civit) #7

Hello @philip.dlcruz,

Could you try with the last Penguin version? Be sure that you are downloading the 64 bits version.

https://www.rhino3d.com/download/penguin/2/latest

I am waiting for your answer.

Xavi


(Basti86) #8

ok thats interesting. glad its working for you on the laptop. hopefully ill have some luck soon. ill post any success that i have made once i figure it out. thanks for the share mate.


(Basti86) #9

ok ill try that as soon as i can. thanks


(Philip Dlcruz) #10

Hello @Xavier_Civit

The Penguin installer I have tried in the past was already the latest one, SR5 64 bits version. I downloaded it on August 27, 2018.

What happens when I install penguin is that, when I open Rhino 6, I cannot choose Penguin to be the renderer because it is not one of the choices.


(Xavier Civit) #11

Ok, could you check if Penguin is loaded?

If it does not appear in the list, press “Install…” button and select the file Penguin.rhp. It would be in
“Rhino X installation path”\Plugins\Penguin 2.0\

PD: We have updated a new SR5 version this September, it solves some bugs that users reported but It will not solve this issue.


(Philip Dlcruz) #12

Oh! I did not know that my SR5 was an older version compared to the current version. I thought it was all the same, “SR5”, no newer version, for example, SR6. There was no version or build number on the file name or on the website download page.

I downloaded the latest version of Penguin from your link and installed it. I checked Rhino to see if it was recognized. For some reason, it was. It is now part of the rendering options in the menu, unlike before. I did not have to go to the Rhino Options like you illustrated.

Thank you for informing me that the SR5 now was a newer version and thank you for the help!