Pen mode PDF output really heavy


#1

This is the Pen mode pdf output we get in v5.

This is what we are getting in v6. Yuck… Any words of wisdom?
PEN-PEN-SHADE.pdf (206.6 KB)

Thanks!
Jim

Version 6
(6.3.18072.11251, 3/13/2018)


(John Brock) #2

Interesting.
Here are PDF files from V5 and V6 using the same model, and for me the V6 looks a lot better:
V5_Cactus.pdf (287.0 KB)
V6_Cactus.pdf (845.0 KB)

Have you messed around with the Pen display mode settings in V5 or V6?


#3

We 're using the mode without any changes. Your v6 output does look better than the v5, but it IS heavier. Somehow, in our case it seems really exaggerated.

It’s weird, in my layout page, I have pen/wire/rendered/shaded modes in different viewports and they all look much heavier than in v5. However, when printed to pdf, only the pen viewport comes out that way.


(John Brock) #4

If you can send us a small test file that exhibits the problem, it would be helpful.
You can send it to us at tech support.

Include this URL in the message so we know what to do with it:


#5

Hmm it does look like pen mode in Rhino 6 is handling things differently than 5 did. Rhino 5’s output looks more or less the same as it did inside of Rhino. Rhino 6 seems to put out heavier lines but they don’t look at good and it has issues with small details.



pen test R5.pdf (67.1 KB)
pen test R6.pdf (100.3 KB)


#6

I have noticed this, and file sizes seem to be much bigger too


#7

Another quirk to this. When something with pen mode is printed (as in printed on paper) from inside of Rhino the result looks as it does on my computer screen. The same file saved as a pdf has line weight issues.

So as far as I can tell the problem is specifically with how pdfs are being saved. It generally seems fine with simpler models like John’s table, but the output on more complicated models (like Jim’s) is pretty much unusable. Idk what’s changed here since Rhino 5 but it always seemed pretty consistent with how things saved and printed.


(Scott Davidson) #8

Can we have an example file for this to test ourselves?

The output from PDF through Pen mode is a raster output. That means there are more steps that we need to consider when trying to compare output.

  1. There is a resolution of the output.
  2. Video Card and driver might be important. We rely on the cards to do Pen mode.
    3 And it is even possible the resolution of the monitor matters.

To start, let us all work with a common 3DM to test and compare systems. Is there a good file to start testing?


#9

Thanks Scott. Is there a preferred place to send files too?
And for the other info…

I’m using 2 1920x1200 monitors (Dell U2412M)

SystemInfo:
Rhino 6 SR3 2018-3-13 (Rhino 6, 6.3.18072.11251, Git hash:master @ c0a2028629d3ed3a538f0854c8ba021ae8c678b7)

Windows 7 SP1 (Physical RAM: 32Gb)

Quadro M5000M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 376.54)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

C:\Users\pshuell\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\ProRender (2aae3eb3-985b-4e64-b19a-fed69ef9dfeb)\2018.1.18.804\ProRender\ProRender.rhp “ProRender”
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Brazil 2.0 for Rhino 6\Brazil.20.v60_x64.rhp “Brazil for Rhino”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Scott Davidson) #10

Yep, you can throw it up here: https://www.rhino3d.com/upload

Your setup is very similar to mine, so we should see similar results. There are inherent differences in the way the pen mode and the way PDF outputs in V6.

Which PDF printer were you using in V5?


#11

Great, a file should be uploaded shortly. I’ve been using the Adobe PDF printer in both Rhino 5 & 6, and otherwise they’ve been working great.


(Scott Davidson) #12

Thank you, I have the file. We are seeing some thicker lines here also. Do you ever print PDF and a get a blank print?


#13

I haven’t gotten a plank print using Adobe pdf. I’ve tried Rhino pdf and got a blank page except for the pen view details. Now that I’m trying it on the file I sent you Rhino PDF is causing it to crash, I haven’t had that problem on other files though.


(Scott Davidson) #14

On the PDF crash did you get a crash dialog? Did you fill it out with your email address? I can track that and see what is going on.


#15

I tried it again and sent in the crash report. If I can have influence on the order of these things the pen mode issues are more important to me than the crash :slight_smile:


(Steve Baer) #16

I’m able to repeat the heavy line work bug and am currently working on a fix.