Pdf raster output resolution


not strictly a V6 Wip topic as I believe it has been asked about in V5 already, but I can’t seem to find any option to set the resolution of the initial raster image when exporting to pdfs.

meaning they are always too low in resolution to look good, but the settings inside (eg. downsampling off) have no effect on the quality.

So I assume there should be an option defining from within rhino what DPI to output in relation to page size.

does it already exist or if not could we please get it for V6?


I have DPI settings here using the PDF995 print driver…

Any luck finding the same with your driver?


thanks for your tip.
I am aware of this setting.
Have you checked the resolution you get from raster output on different settings?

Here nothing ever changes. (eg. 600 to 1200 dpi; 2400 is not printing successfully>pdf 24 window never pops up )

afaik this parameter only concerns with the vector art flattening precision for lines ,hatches etc. when transfering from rhino units into the pdf unit space.


Hi Brian,

I have an update for you, In a way it seems we are both rigth:

the setting you showed does indeed change the raster resolution, but the parameter seems to only work correctly up to a certain page size.

I am outputting architectural drawings on 1.5m x 0.6m paper in this case, please see the zoom in,
the first 720 dpi the second 1200 dpi. there is no difference visible. the aliasing is almost identical.

However if I print detail pages on A3 turning fron 720dpi to 1200 dpi does make things a lot crisper.

I tried with pdf24 and adobe pdf an both won’t print @2400dpi. Also the step is really hefty from 1200 to 2400. I don’t quite get the setting. The thing is if I switch to image output in Rhino I can export gigantic pixel dimensions… this example is the original page size output at 360dpi via the image printing option.

It would be really great if we could get such a raster quality directly into a pdf!?


I can’t print a 2400dpi PDF using the PDF995 print driver either but 1200 works fine at that custom paper size. I’m not sure if this is a PDF limitation or due to the specific print driver used. @stevebaer do you know?

I created a youtrack issue for this at
and will dig into it when I have some time

Thank you for checking up on this topic.
let me know if you need any more info.

sometimes we don’t want to give away vector pdf of our plans but still need a good raster quality,
and I have been fighting with this particular issue for a while, would be cool if it can be improved.

btw, it is not like I have no good things to tell either :wink:

for this sort of 2d plan work V6 is between 2-10x faster than v5.
I mean especially block management, block editing, and display with (like i described here: Disable redraw on inactive viewports )


A little background…
There is code in Rhino that degrades the resolution when very large raster outputs are generated because these images can become so massive. This code was written back when Rhino ran in 32 bit. I’ll try removing this degrading step and we can see if anyone runs into cases where their PDFs become too large to manage or their computer locks up due to the sheer massive load of work to do.

Hi Steve,

thanks for the detailed infos on this, it well explains what I have been seeing.
Since you implemented the OpenGL Image-print feature in Rhino years ago it basically never crashed on me hen outputting massive resolutions, and it is still very fast.
The biggest files I have tried to raster where somewhere between 20-30k horizontal resolution.
Luckily modern large format printers can handle big bitmaps quite well, so in case there is 3d geometry being printed together with line art, since we can’t yet output vector/pixel mix via pdf, we just go for big image files in the right paper dimensions.

Hi dk2079.

With Adobe Acrobat Pro, under printing preferences, advanced options, 2400 dpi, 3600 dpi, and 4000 dpi are standard print resolutions.


Hi Barry,

the 2400-4000dpi modes won’t work with large paper dimensions like A0 and such.
Steve confirmed this two post above.

It will work on smaller page size like A4/A3


RH-34546 is fixed in the latest WIP

Hi… new user here…

Was a solution ever found to this??

I need to print rastor output for a house (plans, sections, elevations and perspective 3d views). These images are direct from the visual arq house model (turning levels off/sections on etc) and have been placed on an a1 size layout via viewports.

I’m am printing to Adobe pdf. I have to select rastor so it doesn’t all turn to lines (showing floors below or lines beyond).

The printer output is not great at all. What settings can I change to avoid pixelation/bad quality flat plans/elevations?

Many thanks,


Hi - we have an open bug report about that issue - RH-49677.

Cool thanks I will have a look :+1: