PDF Printing Issues


I am trying to print a PDF from my drawings, I set up a layout and usually I would hit print and it would save the file and I could carry on, But for the last two days the Adobe PDF window is getting to about 80% before it stops, the in Rhino Printing window displays a progress of 0 the whole time. Anyway after it gets to 80% it just stops, can close the Adobe PDF window but it just goes to the task tray. I can hit cancel in Rhino but then it becomes unresponsive and I can’t actually do anything with it and I have to end the process.

Has anyone had similar issues or has any idea why it’s refusing to print PDFs that it was creating absolutely fine 3 days ago?

I have tried this in Rhino 5 64bit and Rhino 5 with the same results.

There are no bad objects either

Hmm, It also just produced this error report when I shut it down just now:

"%%[ Error: syntaxerror; OffendingCommand: --nostringval-- ]%%


%%[ Flushing: rest of job (to end-of-file) will be ignored ]%%
%%[ Warning: PostScript error. No PDF file produced. ] %%"

Hi Artstep, what happens if you use another free PDF writer such as PDF 995 - http://www.pdf995.com/ or CutePDF - http://www.cutepdf.com/?

Hi artstep, and @stevebaer ( are you still the man for printing?)

I jump in here because I have experienced odd pdf printing behaviour all of a sudden as well.
In my case I have the pdf24 creator.

What has happened somewhere in the last week is that I get no (proper) preview in the print dialog.
In the end the pdf is printed as expexted, but the preview lacks completely.
When switching papersizes I get a preview in some cases but it is not predictable.

I report in because this might be related.

Since I did not update either Rhino nor the pdf printer, it might be a windows update that acts up?


Well I’ve come home and tried it again just in case with Acrobat but it seems to be working again. It’s strange because I was struggling to print yesterday and then my computer was off all night and in the morning it was completely refusing to print…

I guess panic over…

Sorry about that…

Though I wonder if Willem’s problem could be resolved by a restart as well…


EDIT: Actually now that I think about it the difference between now and this morning is that the battery was almost dead when I was working, I wonder if it was the computer running with reduced power that caused it, I’ll run the battery down low again and see if similar things start happening