PDF export Straight Line Artifacts


I’m exporting Rhino PDF files from the Perspective window. I get strange straight lines appearing, which do not appear in the viewport. Also, these lines do not appear if exporting a png.

This seems to happen more when the camera lens length is very short (10-20mm)
Any thoughts? Thanks!
Mark Lloyd.

Hello - Can you post an example Rhino file, or send to tech@mcneel.com, with a link back to this topic in your comments?
(Pretty cool-looking though)

Thanks Pascal, I’ve just sent a mail to Mcneel, with the file.

I agree - lines look cool, so I suggested a “BUG ON/BUG OFF” toggle!
Mark @skopelab


Hi Mark - so far I am not getting that here… in fact when I try to export to pdf, the view zooms out. Print works as expected though - are you using Print or Export?
junk.pdf (2.1 MB)

Hi Pascal,

I’m using Print.
You really need to set focal length short .

I’m including two files for you to compare (focal length was set at 5mm for these)

1/ Printed as a png directly from Rhino
2/ Printed as a pdf from Rhino, then imported to Photoshop, and then exported as a png.

Crazy no?
Not only is the pdf export covered in straight lines, but there is a whole other form (on left of screen) that appears!
WOW! I think we’ve travelled into a higher dimension.


Hi Mark - the lens length is 5 in the pdf I made - can you run SystemInfo in Rhino and copy/paste the results? This printing stuff is closely tied to openGL and the video card, and that may have an influence. I’m told.


Here you go Pascal.

Rhino 7 SR2 2021-1-21 (Rhino 7, 7.2.21021.07001, Git hash:master @ 96ff97351fbdf5d2acdeaf781aea1577f2ff60f7)
License type: Commercial, build 2021-01-21
License details: Cloud Zoo

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [95% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 4GB, Driver date: 10-22-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.57

Integrated acclerated graphics device with 4 adapter port(s)

  • Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 7-8-2020 (M-D-Y).

Integrated graphics device with 3 adapter port(s)

  • Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-22-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\mlloy\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\Fologram for Rhino (468a328b-20d9-494b-b9e1-cbe9f827d3a2)\2020.2.1.2\6\Fologram.IO.Rhino3d.Win.rhp “Fologram for Rhino” 2020.2.1.2
C:\Users\mlloy\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.20335.757
C:\Program Files\SimLab\Plugins\SimLab 3D PDF From Rhino 6\plugins\SimLabPDFExporter.rhp “SimLab PDF Exporter”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\export_PDF.rhp “PDF Export” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Just an additional screenshot - interesting!

Hi Mark - Can you please see if disabling the plug-ins listed here

in Options > Plug-ins page, and then closing and re-opening Rhino (important), makes any difference? If so, re-enable one at a time and see if you can figure out the culprit. If not… I’ll need to ask a bigger brain.


Hi Pascal,

I’ve just tested your suggestion, and no change I’m afraid. I went through shutting everything down and rebooting also.

I’ve retested some exports to see (with a different file) - increasing the focal length sometimes removes these straight lines in the print setup window, but when opened in illustrator, they are still there.

Any help most appreciated!

Hi Mark - something to try - in Options > View >OpenGL switch of GPU Tessellation and see if that does anything. BTW, do you have more than one monitor on this machine, an external one?


Ive just tried turning off GPU tessalation - no change.
Yes, I,m using an external monitor 4K monitor.

I’ve just switched to my laptop dispay, disabled the external, but same result.


Hi Mark - I’ve been chatting with a developer… can you try a couple more things:

  1. Run ViewCaptureToFile at that high resolution 5100 by 6600 - does the same thing happen?
  2. In Print, bring that number down to say half in each direction. Does that make any difference?


Do those lines go away in raster output? If so, I suspect those are the result of a specific camera set up that we’ll need to be able to repeat the issue.

Hi Steve - I do not see the lines so far here in Mark’s file. But it is an extreme camera setup - 5 mm lens.
I do get a better reproduction of the viewport with raster output - with vector there is some stuff missing but no extra stuff.


Yep, that’s most likely the case where the math behind the transformation from 3d → 2d is causing stray lines to be introduced into the output.

Hi Pascal, Steve,

I’ll do the tests, and I’ve already set up a named view, which I’ll include with the rhino file which I’ll resend. Will send all ASAP.

Thanks for you attention,

1 Like

Steve, Raster has always worked fine, but this of course locks down the line width and definition of the file. I import the vector file into illustrator, then am free to do what I like at a later date.

For info, I’ve only come across this starting at around 20mm focal length and below.