Part of the points cannot be projected on meshes

Hi, everyone,

I’m a learner at Grasshopper. I tried to project some points on a terrain mesh. I adopted the “project point” component. Originally, it worked well. All the points can be projected on terrain. But when I updated Rhino from 6 to 7, some points within the base data cannot be projected on the terrain mesh with the same base data and same script. The output is “null".
I attached the script, pls help me have a look. Many thanks.


Entrance_pts_projected_on_terrain.gh (400.2 KB)

Regards,

Jing

It seems working well for me(SR7).

One thing to point out is that your mesh is located far from the origin point. Relocate your mesh and points to near the origin and try again.

1 Like

Earlier Rhino 7 versions had problems with points far from the origin.
In 7 SR6 and SR7 RC, the problem is fixed.

See RH-62060.

2 Likes

Thanks, Kim. When I move the mesh to the origin point, the issue is fixed. Many thanks.

Thanks for your reply, Giulio. I checked my Rhino license. It shows me that it is version 7 and issued on 12/08/2020. But I can not figure out whether it is 7 SR6 or SR7 RC. Can you give me more hints? And does it mean I should update my Rhino?

When you have a Rhino 7 license you are entitled to update to the latest service release of Rhino 7. You generally check with the Rhino command _SystemInfo, where the first line will tell you what service release you have.

You can update Rhino by going to Help > Check for updates.... Rhino 7.6 is the current service release, Rhino 7.7 is the current service release candidate. You can change update frequency from service releaes to service release candidate in the same dialog.

2 Likes

Thanks for your detailed guidance. It’s helpful!:slight_smile: