Parametric Plane Truss Error - "MyAnalysis Could Not Find GPs!"

Hi Dr. Bauer,

I am trying to run a parametric truss analysis and am getting an error upon running.
“NodeLoad of ID 17 does not exist!”

Any ideas on how to fix this error? I imagine it’s a simple fix, but I can’t seem to figure it out!
Thank you so much for developing and working on this amazing tool, AND for spending time in support!

Nicolas Ramirez

Mill Creek Truss Design.3dm (177.0 KB)
Parametric Mill Creek (29.0 KB)

the load type is wrong. You can just choose within the provided values. “Live + Dead” is wrong. This input only describes the behavior of the load projection.

1 Like

Anna, thank you so much for the information and quick fix! I had no idea and would never have fixed it on my own. I understand the function using a value list input now.
Thanks again for your amazing work :smiley:

Hi Anna,

Back at the questions again…
I am no longer getting errors but the results don’t display when selecting them! (Deformed Model and 1D Results)

I have the ValueList with outputs checked.

I have also tried saving the model and script in a path with no spaces.

Mill Creek Truss Design.3dm (176.2 KB)
Parametric Mill Creek (29.8 KB)

Any ideas?

Thank you

There are also curves with length zero. Kiwi can not handle them and you have to remove them from the curve lists.

Thank you so much, Anna!