Overwrite Family Issue

Not sure why I’m having this issue. I am able to push the Geo from Rhino to Revit without a problem. However, if I edit the family in Revit and then try and overwrite it from Rhino again it continues to revert back to the overwritten version in Revit. I’ve tried the overwrite option on the components and nothing seems to fix. Any help is appreciated.

Thanks!

Overwrite Family in Revit, wont revert to original geometry|690x296


test.3dm (213.8 KB)
Test.rvt (752 KB)

I recreated your definition and everything works as expected. Did you change the Element tracking from the Default Enabled perhaps?

I tried both methods of tracking and seem to get the same issue.

Heres the steps I had done:

  1. Push Geometry to Revit through the definition
  2. Edit the family in Revit family editor
  3. Load back into Revit (overwrite the existing version)
    4A.Tried unpinning and deleting family in Revit, and reloading from Rhino. Geo reloads as modified family in Revit not Geo from Rhino
    4B. Tried Just reloading from Rhino with both tracking modes, still reloads in Revit as modified from Family editor.

Confused as to why it maintains the changes from the family editor even If I have overwrite set to true in grasshopper and delete the family?

Thanks for the help

I was able to replicate. I would expect the Rhino to Rebuild at that point as well. I’ll make a bug report.

  1. Create Family from Rhino Geometry
  2. Open in Editor, modify geometry, push back into Revit.
  3. Change Tracking to Replace does nothing.

The expectation would be that Replace would overwrite the family.

recreate test family.gh (12.3 KB)

That’s what I would expect as well. Thanks for taking a look, I’ll keep an eye out for a fix.