Osnap not working Rhino 7

I have the same problem with Osnap not working, it won’t turn on, and I’ve tried everything you have mentioned above… please help:(

this is the systeminfo:

Rhino 7 SR36 2023-12-12 (Rhino 7, 7.36.23346.16351, Git hash:master @ 11a364321297eb8cdb34405a3308d8911f58706d)
License type: Educational Lab License, build 2023-12-12
License details: LAN Zoo Network Node

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 15Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 12-16-2021 (M-D-Y). OpenGL Ver: 4.6.14761 Compatibility Profile Context 21.30.23.04 30.0.13023.4001
> Integrated accelerated graphics device with 5 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 12-16-2021
Driver Version: 30.0.13023.4001
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 512 MB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi, the osnap is not working on my rhino 7, I’ve tried everything (including statusbar and testResetWindowPositions), but nothing changes. Please help me!

This is the systeminfo:

Rhino 7 SR36 2023-12-12 (Rhino 7, 7.36.23346.16351, Git hash:master @ 11a364321297eb8cdb34405a3308d8911f58706d)
License type: Educational Lab License, build 2023-12-12
License details: LAN Zoo Network Node

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 15Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 12-16-2021 (M-D-Y). OpenGL Ver: 4.6.14761 Compatibility Profile Context 21.30.23.04 30.0.13023.4001
> Integrated accelerated graphics device with 5 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 12-16-2021
Driver Version: 30.0.13023.4001
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 512 MB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hei Synne -

Could you describe what that means? When you run the Osnap command, can you set the options?

Your GPU is rather underpowered and running on very old drivers. I’d open the Notifications panel in Rhino and follow the links to see if there are newer drivers available.
-wim

When I click the osnap, the layout kind of only zooms in and out a bit, yet it doesn’t turn on. So when I for example try to draw a line from a point, it won’t snap to it. I tried downloading a new driver, hope it helps, thank you! But how can I fix the osnap further?

I can set options, but it doesn’t help anything that I have tried.
I updated the driver, and this is the new systeminfo:

Rhino 7 SR36 2023-12-12 (Rhino 7, 7.36.23346.16351, Git hash:master @ 11a364321297eb8cdb34405a3308d8911f58706d)
License type: Educational Lab License, build 2023-12-12
License details: LAN Zoo Network Node

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 15Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 2-20-2024 (M-D-Y). OpenGL Ver: 4.6.0 Compatibility Profile Context 24.3.1.240216
> Integrated accelerated graphics device with 5 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 2-20-2024
Driver Version: 31.0.21912.14
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8126 MB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hei Synne -

I’m not sure if that means that the checkmarks are not appearing in this panel:
image

-wim

Thank you so much!!! It works now :smiley: wish you a wonderful day, and thanks again :blush:
Synne

1 Like