Orbit is off axis

Hi. I am trying to orbit around my perspective viewport like I normally do using right click and drag. Usually this rotates around a vertical axis, but now it rotates completely off axis and is really throwing off my workflow. Is there an easy fix to this? I have tried playing around with the Options → View settings, but it hasn’t solved the problem.


Maybe check the rotation angle is 0, I’ve seen it happen a few times.


1 Like

That didn’t seem to work. The rotation angle changes as I rotate

There are three related methods: Gumball command, Zoom command, and Options>View>Rotate settings.

If you select objects and use Gumball, it will change the view target to the center of the bounding box holding these objects. The automatic change of the target is very useful in the Perspective viewport. The right mouse button + mouse movement will rotate the view about the center of the bounding box.

The Zoom Selected and Zoom Selected All commands have the same effect. They are associated with standard keyboard aliases: ZS and ZSA.

Options>View>Rotate settings (shown in the following screenshot) determine how the view rotates, tilts, and tumbles in response to the right mouse button + mouse movement. These settings are impossible to explain - you have to experiment with them to understand them.

Have you tried setting this to 0 ?
I use Rotate around world axis option in the settings.


OK, I think this worked. My view setting is set to world “rotate around world axes” and my rotation is set to 0, and it is working like normal. Thank you very much