OpenNest not working on Rhino8 + Macbook M2 Pro

Hello everyone and @Petras_Vestartas , I currently can’t use OpenNest on my machine.
I’ve tried everything that could show up on basically any forum.

This error message shows up when trying to use the plugins components:
Solution exception:Could not load file or assembly ‘OpenNestLib, Version=, Culture=neutral, PublicKeyToken=null’. Could not find or load a specific file. (0x80131621)

You’ll find hereby attached all the necessary informations:

Thanks in advance! (15.7 KB) (3.5 MB)

Thanks for letting me know, just installed Rhino8…

Rhino 8 switched to .NET (Core), as it’s likely the reason.

1 Like

On windows rhino8 it works, macs different version was always issue. Will try to check.

Just to check: does it work with Rhino 7 (under Rosetta)?

I tried undergrading to R7 but can’t since I only have a licence for R8. Am I missing something?

Hi Walter -

If you have a new and personal Rhino 8 license, you can get a license key for Rhino 7 - see Rhino - Access Rhino 7 for requirements and download.

1 Like

@Petras_Vestartas following the previous suggestions, I tried the plugin on R7, and it works (see the screenshots). The thing is, due to port 443 being not open I wasn’t able to confirm my licence key on R7, so I won’t be able to use this version of the software for more than five days.

So OpenNest works on R8 windows, and R7 macOS, but so far not on R8 macOS
Any help to figure out the problem would be very much appreciated!

My guess is that is has sth to do with AppleSilicon.
RH7 runs under Rosetta. RH8 not. The same situation is with the Karamba plugin. Plugins probably need to be recompiled or sth.

But that is just my guess.

Thanks for the clarification Rudi! Do you think that, if you’re right about it, we can do something to make OpenNest work simultaneously on my machine and latest version of Rhino?

I think that OpenNest probably has to be recompiled in order to work on native AppleSilicon. However my software knowledge is limited, @Petras_Vestartas might tell you more…

Edit: just checked, NGon also does not seem to work on AppleSilicon RH8:

Exception System.IO.FileLoadException: 
  Message: Could not load file or assembly 'NGonGh, Version=, Culture=neutral, PublicKeyToken=null'.
1 Like

Of the ones I have tested (Karamba, OpenNest, NGon), these have native assemblies (non .NET) that are compiled for x64 only. If you right click on Rhino > Get Info, and check Open using Rosetta, it should get these working. However, do note that since Rhino will be running in x64 on Apple Silicon, it will not be as fast but should at least match Rhino 7.


I think you were right! Seems to be the solution. Thank you very much good sir!

@curtisw, what can the devs of Lunchbox, OpenNest, Ngon do? Do they just have to recompile the plugin, or are there some deeper rooted issues with all the libraries, that have to be native AppleSilicon first?
If there are some general things, that can be done, maybe this could be added to the McNeel developer documentation?


Hey @rudolf.neumerkel, I would assume if a developer has included a .dylib (a native assembly) they would have the means to update that to a “universal binary”, needed to support x64 and apple silicon. There is a cornucopia of documentation on how to do that on apple’s website here, otherwise it’s a short google away.

That being said I think it would be prudent if we had some documentation/mention for this. I’ve created RH-78671 to address that.

Thanks again for keeping us on our toes!



Thank you @curtisw for this, the mac compilation was always an issue depending on different machine…

@Petras_Vestartas, where you able to solve the compatibility issue for OpenNest and NGon?

Thanks a lot, cheers,