Omniverse Rhino bug export usd file

Hi everyone,
I’m trying to export usd props file in nvidia omniverse plugin. But all usd files are 2kb and don’t export meshes. I already reinstalled the omniverse plugin in Rhino. Nothing seems to work.
My Rhino project is subD.
What is wrong?
Help me please!

Can you attach the files here?

Sorry for taking so long to respond.
I ran more tests and found more bugs in the latest Omniverse Rhino plugin.


Omniverse does not export SubD geometries

Omniverse exports mesh geometries without preserving object names

Omniverse exports duplicate mesh geometries


Files Link:

Hello, I seem to be running into this same issue - SubDs not coming over.

The extremely weird and frustrating thing is it was repeatably working (same file) for me, but others were getting this problem (again with exactly the same rhino file). Then today, out oft he blue, I started getting it too and no matter how many times I retry, it’s the same broken result.

Did anything get resolved for you, and if so, what was the solution?


PS - I tried your test files and get the same behavior. Is this something that’s going to be fixed? It breaks our workflow completely.

We can’t speak to the Omniverse Rhino Connector but we do have a USD export option in Rhino 8. In it’s first iteration it doesn’t support SubDs but we will be working on that.
Here’s a discussion in case you haven’t seen it:

Ah, thanks for the quick reply and link Alain!

Should I take from your response that the OV connector was developed by Nvidia? When I found this forum post and Nathan’s reply above I assumed it was a McNeel product.

Thank you again!

Yes, the OV connector was developed by Nvidia.

1 Like

Thanks Steve - I have a question in over there, and will post any info I get back here.

Kind Regards

the current connector does not support sub-d right now, convert to mesh or nurbs. the USD export in rhino 8 might @stevebaer