Odd and annoying zoom (?) refocus

If I Zoom Extent then Select an item towards the top of the drawing, then Copy it towards the bottom of the drawing which requires zooming in close to select the correct point. After placing the item, attempting to zoom back to the complete view with a 3Dconnection SpaceMouse (and this could be the trouble) you are unable to do it, the view point of the camera seems to have changed, you seem to be stuck squashed up against the drawing (zoomed right in). The only way to get out of this is to rotate around the back of the drawing, then zoom back out, or select Zoom Extent again.

I’m pretty sure this started happening some time back in V6.

Hello - try UndoView in this case.



thanks for the reply. I forgot to mention in the original post that this is in V7

Not sure when I’m supposed to use your suggested command, I’ve tried before starting the above, and at the end of the above when the issue appears, neither help.

Rhino is obviously doing something that someone thought was a useful function, I just can’t imagine how it could be useful. I’ve just disconnected the 3Dconnexion SpaceMouse and the issue doesn’t appear to happen, though I’m having trouble moving about and zooming without the SpaceMouse.

Hello- if you zoom in and UndoView, that should restore the view to whatever it was before you zoomed.



again, thanks for replying.

I can see that that is what that instruction does, but if you look at my original post, what I was trying to get across is the fact that when using a SpaceMouse (and it doesn’t seem to do this without the SpaceMouse connected) at the completion of certain functions the camera (?) position seems to be moved.

I think if you had a SpaceMouse to hand and tried it, you’d immediately think the behaviour odd. Again, I think this behaviour was introduced into V6 some months back.

While on the subject of the SpaceMouse, would it be possible to have an option for Return to be assigned to one of the buttons, this is possible in the 3Dconnexion software for other apps. It’s a function I used to be able to do in V5 and V6 up until some six months ago.