Objects turn transparent when changing environment mapping type

unhandled

#1

I have a .jpeg image that I want to render as a screen background. However, my objects turn “transparent” when mapping as screen. When I turn to spherical mapping objects are fine but not the background.

Any ideas?


#2

Hi Andres, this gave me hard time too. The solution is super-simple.

What you see is not transparency but super-primitive (screen) reflections. To change reflections from screen mode (which sucks), you have to override reflection (or refraction for transparent materials, not your case). Simply copy-paste the map from Background to Override - Reflection and change the mode to spherical for reflections only.

Does it work?


#3

What you explained doesn’t work for Reflection override but GI override instead. However, when I turn on V-ray infinite plane (planes’ diffuse layer is mapped with same image as background) problem reappears.
You can see on my image that I have horizon slightly offset where color is more intense. I’m using an infinite plane to catch the shadow of an object.


Does this have something to do with color space inside map settings? I read somewhere that I should use Screen Space (sRGB) setting when rendering on .jpg background.
Also, I’m using BruteForce as my primary, and LightCache as my secondary engine.


#4

I use sRGB for jpg backgrounds too.