Objects are displayed wrong in rhino viewport


(Petr Benes) #1

Hi,
I would like to know, what causes this problem and how to solve it or if it is any bug on your side.
After few last Rhino SR updates some of our files contains objects, which are not correctly displayed in viewport.
If you choose shaded, rendered or ghosted display mode, you see some artefacts in specific camera angles like some orphan planes are moved from the original objects. If you choose wireframe display mode, no artefacts are located in place where are visible using another display modes. But when you render it it will render this artefacts too.

I have rhino file to share with this problematic objects.
Also i uploaded images to demonstrate what i am talking about.

I found that if i explode this wrong objects and join them back, the artefacts disappear. But I can’t do it for all objects in large complex scene,

Do you have any easier solution to fix that all?

See the images:

here artefacts on the right side

Here another example in larger scene. See the artefacts on the right middle of the picture - black wall with orphan fixtures around …


Surface edges are displayed wrong in rhino viewport
(Petr Benes) #2

Another finding: It happens when copy/paste some objects from one scene file (created by someone else) to another one. Can this be related?


(Willem Derks) #3

Hi Petr

I’ve had this happening in the past as well. I do not remember if there was a specific cause and/or solution. I seem to remember that indeed it was caused by a copy/paste as if the pasted objects referenced to a wrong render mesh or somthing like that.

For now what I would try:

-Run the command RefreshShade on the affected or all objects
does that help?

-Check if your display drivers are up-to-date if not; update them.

What type of objects are this? Regular Rhino geometry, Blocks, Meshes or Nurbs?

-Willem


(Petr Benes) #4

It is all regular nurbs rhino geometry.

I found now it can be used ClearAllMeshes too.

But it is curious, because it did not happen. I am using rhino every day for 6 years :wink:


#5

I’m not familiar with the problem in Rhino but am in Sketchup. The problem was solved in Sketchup for me by exploding (ungrouping) the object till the smallest part then use the command show and regroup all. Worth trying I think.

Jordy


(Pascal Golay) #6

I’d like to reproduce the problem here if I can- does the other user have plug-ins that you are not using? Can you possibly post here or send me (tech@mcneel.com, att’n: Pascal) the file that is the source of the pasted objects?

thanks, Pascal


#8

Thanks PiT_79.

ClearAllMeshes worked for me.


(Pascal Golay) #9

Are, or were, the objects far from the World origin?

-Pascal