Objects are located in two separate positions

Hello folks. My name is Justin Schumacher and I’m a school teacher. I started teaching the program Rhino this fall for the first time & I love it so far. I have experience using SolidWorks, AutoCAD and Inventor as well.
I have a student that created a file that has an issue that [so far] I have not seen yeat & do not have a solution to. The student created an object in Rhino. When he re-opened his file, the objects were located in two separate positions. One position was ‘selectable’ but only displayed as a wireframe. The second position was not able to be selected, and it was being displayed as a rendered object [the viewport was not set to rendered view]. There are a few objects with this issue. Additionally, the rendered, un-selectable objects are all located down the ‘X’ axis.

Any help that anyone can give me will help me, and renew my students faith in me!! hahaha.

Thanks in advance for the help


It might be helpful if you can post the file. Just grasping at straws here, I wonder if the objects might be very far from the origin, in that case what looks like a “rendered” view is the objects display mesh which no longer corresponds with the object ue to single point precision mesh calculations.

Are any of the objects bad (SelBadObjects)?


Also might be worth taking a look at your graphics drivers. Make sure you have fairly new drivers. That seems to fix a lot of display issues that we run across.


This used to happen a LOT with blocks, but seems to have gotten better. The frustrating thing about it is that it was never very repeatable, so creating a good example was never easy. If meshes in one place, wires in another bug is repeatable in your file, please post or send it in.


Full Robot.3dm (2.1 MB)

The only way i could upload was as a ‘small’ file. The issues [if they are visible] are located at the base of the ‘robot foot’

I will see if the system admins can look at updating the drivers. I have zero access to the control panel on the school computers. Thank you for the advise.

When I open your file, there seems to be just one set of geometry and it is selectable. Is this image what your model should look like?

Yes, looks OK here, no bad objects and no other anomalies that I can see. --Mitch

I just checked this file and on this end I see no problems.

All my best … Danny


I deleted much of the geometry so the file would be smaller and I would be able to upload it. The issue is with the ghosted images located between the ‘feet.’ Thanks


I don’t see any…

sigh That is most definitely NOT what is being displayed in my file. There are ‘ghost’ images in between the ‘feet.’ the ghost images are RENDERED objects and they are the three cylinders that are located inside the helix. I was hoping this was a common issue. It looks like it is not!

here is a pic of what the display issue looks like on [another] model with issues

You don’t need control panel access to see what drivers Rhino is using. Post a screenshot of the Options>View>OpenGL page. If I had to guess, it is a video card/drivers issue.


I really appreciate the advise and the guidance! Thanks brotha!

Can’t say it is for sure the solution, but those drivers are quite old. I’d contact your IT dept. to try updating a machine that showed this problem with the latest certified for Windows drivers from Nvidia - looks like 340.52 from July 2014. I’d start there.

Couldn’t hurt to try RefreshShade on the problem files, too, though doubt that will fix it.

1 Like

GREGB!!! RefreshShade FOR THE WIN!!

That did it my man! thanks for the advise and the fix brotha!

Ha, glad that worked!