Object Name Bug


Anyone have trouble seeing object names or editing already named objects?

I was in the process of naming the object, switched to Safari to google something, then when I went back the name was gone from the Property panel; and while the text cursor appeared, I couldn’t edit it. However, the details do reveal that it is named.

Version 6 WIP (6.14.19043.12076, 2019-02-12)

I think I followed your instructions but can not duplicate the problem.

Can you provide a step by step procedure to repeat the problem please?

I named an object, clicked away, tried to name it again and could not.

I tried again, selecting a few different polysurfaces and then a polycurve, then I could see the object name. However, I then clicked another object and the properties panel didn’t change, maintaining the previous object’s info. At this point, I clicked more objects until the properties panel updated, then clicked the original object and the name was once again gone.

Seems quite random.

Those are the hardest to repeat so consequently the hardest to find and fix. There are just a boatload of things it could be including multiple selected objects, Groups, selecting object too quickly so you get ahead of timers that might be involved in information updates etc.

Fortunately, it sounds like with a couple of clicks to wake it up, you’re getting past it relatively easily. It’s still a Work In Progress so some other seemingly unrelated fix or change might solve it.
If not, maybe you or someone can come up with a repeatable sequence so it can be isolated and fixed.

1 Like

I’ve seen this bug also.

Seems to be repeatable if you:

  1. Start rhinoWIP
  2. Create a new model
  3. Draw a box
  4. Select the box, in the properties panel set the name to ‘box1’
  5. Gumball drag the box to the right, tap alt to make a copy, and release mouse
  6. In the properties panel change the name of the copy to ‘box2’
  7. As soon as you press ‘return’, the values in the properties panel disappear.

It is not just the name that disappears, also can’t see Layer, Display Color, Linetype, etc…

Click one box then the other - blank values in the properties panel.

If you have one of the boxes selected then click the gear and toggle between ‘Show inspector panels’ and then back to ‘Show Properties Panel’ it will show properties of the currently selected box but does not change if you select the other box.

I quit and restarted the WIP several times then followed these steps - it seems repeatable (for me anyway).

I’m running the latest WIP: Version 6 WIP (6.14.19043.12076, 2019-02-12)


I just tried that in a newer in-house build from this morning.
I have 4 boxes now, some copied by dragging with Gumball and tapping option, then renamed, and others by just dragging with no Gumball.

No problems.


Well hopefully that means it will be fixed in the next WIP release (fingers crossed).


Exactly. There was no public WIP this week as you know. Something was broken about the Sparkle updating tool that would have turned into and support nightmare.

I just checked and they are working on the Sparkle updater fix right now.

sounds similar to this bug on YT