OBJ import

OBJ import is broken. Either nothing is happening or there is a message “Errors occurred reading this file, may be incomplete”.

OBJ import is working here in an internal build from early this morning. Post the OBJ that fails please on your end or wait for this weeks WIP build to test it again.

It is still not working for me with the same result. WIP 2015-11-10.
Sample OBJ that fails like every other:
test-torus.zip (2.6 KB)

The torus obj opens as well as imports here using Rhino 6 SR0 2015-11-12 (Public Build, 6.0.15316.6291) and these settings

Are you using different ones?

Hi Brian,
I’m using the same settings.

Errors occurred reading this file, may be incomplete.
Error importing file "C:\Users\mikolaj\Downloads\test-torus.obj".

My WIP is 6.0.15314.10471, 2015-11-10

Thanks for confirming the settings… I’m not sure why it’s busted on your end. I’m not able to reproduce the exact error message after blocking the Import OBJ plugin.

@tim any idea what might be going on here?

OBJ I/O in Serengeti is a dotnet plugin now (actually all of the functionality is in the dotnet SDK and the plugin is just for the sake of user interface). It uses a StreamReader class that is part of dotnet 4.5 and 4.6. I think the Rhino install is supposed to update (or prompt you to update) your dotnet to 4.5 if you have anything older but I suppose that could get messed up somehow. So, I would check to make sure you have dotnet 4.5 and make sure you have all of the updates for it.

My guess is it’s the StreamReader class is missing. You can try opening a really big OBJ file in Serengeti. If it bails instantly I’m probably right. If it cooks for a while before bailing then it may be something else.


That last comment wasn’t quite right. There’s been a StreamReader class in dotnet for a long time, but I’m using some functionality that’s in dotnet 4.5.