OBJ Export - Texture Issue

texturemapping

#1

Hello!

I’ve been experiencing some issues with my textures when exporting my Rhino model as .obj (or .dae).

The facades textures are exporting fine, but for some unknown reason the roof is getting messed up, no matter what mapping method (surface, box, planar), texture settings or export settings I am using.

The import issue appears in all kinds of programs (SketchUp, 3dsMax, MeshLab, Rhino) when I import the exported .obj into a new file. Also tested the export on a different machine and a lot of different setting combinations.

My rhino version and graphics card driver should be up to date.

3dm model, .obj export with textures and the export settings

https://drive.google.com/open?id=1eM5mLK0UKAxTAujlb_mkcugzaIb-dT6u

Any ideas?


(Tim Hemmelman) #2

For OBJ try extracting your render meshes and exporting those alone. SketchUp and Collada are supposed to use render meshes already to simplify the preservation of block hierarchy in output.

Tim


#3

Hey @tim ,

thank you very much for your help!

Unfourtunately ExtractedRenderMesh didn’t change the output result.

Any other ideas?


(Tim Hemmelman) #4

It has something to do with the texture coordinates or the image(s) being used. You’re tiling the roof tile image, right? There may be someway to bake a texture and use normalized texture coordinates but I don’t really know that stuff. I primarily do file I/O. Since you have one roof surface that looks right and one that is not getting tiled properly you could export only those (extracted render meshes) to OBJ and then look at the results in a text editor. If they’re using the same bitmap then it’s definitely something to do with texture coordinates. Sorry I can’t help much more than that. If you want to send me the roof portion of the 3dm model (with the corresponding textures) I can try watching what’s going on in the debugger).

Tim


(Tim Hemmelman) #5

One more thing, just making sure. After you used the command ExtractRenderMesh, did you only export the results from that command? You should not have gotten any mesh dialog on the way out.


(Pascal Golay) #6

Hi Steven - try exporting the mesh ‘Unmodified’ rather than ‘Welded’.

Hm - nope, same problem… I guess the mesh bits are not joined anyway.
-Pascal


#7

Hey @tim,

Yes I want to tile texture the roof with the image.

I used the command _ExtractRenderMesh on my surface model and selected the created meshes with _SelMesh. If I export the selected mesh with _Export, I still get the two dialog windows. (If you mean them)

OBJExport_Mesh

PolygonMeshDetailedOptions

If you still could take a look at the file in the debugger. Here is the 3dm file of the extracted render mesh.

OBJExportIssue_Roof.zip (1.3 MB)

The original file can be found here:

https://drive.google.com/drive/folders/1eM5mLK0UKAxTAujlb_mkcugzaIb-dT6u

@pascal

Thank you for trying. I tried it aswell, didn’t fix it for me either.


#8

Sorry if this does not respond to the problem:
What’s funny is that I just can’t test the resulting obj export within RH6. Rhino hangs after passing the obj options window then it freezes with obviously an infinite loop, I have to kill the process (no log) but an information in the command line before I kill rhino: (sorry, in french) “Le chemin d’accés n’est pas une forme conforme” .
Isn’t it a VisualBasic message ?
I have no error if the mtlib is ignored.


(Pascal Golay) #9

Here there is no difference if I use an extracted render mesh or the Mesh command - if I export both sides of the roof, one of them is incorrectly mapped on reading the resulting obj file.

@ZSteven - for now, and I realize you should not need to do this, but you can make a small planar map, like so:
image

And set the texture repeat to 1 rather than 14 and that seems to work…

image

-Pascal


#10

Hey @pascal,

thank very much your for that tip! It is a bit time consuming, since I need to do this “treatment” for many more buildings and the terrain, but atleast it works for now.

I would love a fix but I guess the bug is of low priority.

Anyway, thank you once again.


(Pascal Golay) #11

Hello - the original bug is in the hands of the developer - I don’t know that it is low or high priority in the big picture but it is ‘on the pile’

https://mcneel.myjetbrains.com/youtrack/issue/RH-50379

-Pascal