No templates or toolbars in Rhino 5 on Windows 10

toolbar
maxwell
windows10
bootcamp

#1

Hi

I was delighted to find out that my working app combination Rhino + Maxwell render now is available for mac. However, the Maxwell plugin is really not production ready and the workflow in the Rhino for Mac is somwhat crippled aswell, so I’m feeling forced to switch back to Windows for now.

I’ve installed a fresh Windows 10 installation on Bootcamp on my macbook pro, but I won’t get any templates or toolbars in Rhino. Some observations:

  1. I’ve used the latest Rhino 5 SR13 download from your site.
  2. ToolbarReset does nothing for me
  3. The little splash screen “updating toolsbars etc” shows every time rhino starts but does not seem to do it’s job.
  4. I’ve tried extracting the Language-MSI from the installer and explicitly install that one.
  5. I am local admin on the computer and I’ve tried starting rhino in safe mode aswell as and administrator (by right clicking)

On a side note, all the icons are too tiny to see, how can I adjust this? ( I saw this on the Maxwell Plugin which I managed to install).

Regards

  • Björn

(Pascal Golay) #4

Hi Bjorn - did you run the full installer from

http://www.rhino3d.com/download/rhino/5/latest

?
To make the sizing behave better, see
https://wiki.mcneel.com/rhino/5/video/highres/toolbars_and_text_too_small_in_64-bit_rhino_5_on_high_resolution_screen

But also see the warning message about upgrading Windows to ‘Creators’ -

-Pascal


#5

Hi Pascal

Yes, I used that link you provided to download the latest version of Rhino.

As of the Creators update note, that’s interesting. However, I bought windows online yesterday, I’m not sure if that was the creators update or not. I was not aware of the issue and don’t remember if I even got a choice when I bought it.

  • Björn

(Pascal Golay) #6

Hi Bjorn - if you just installed Windows, you’ll want to make sure you have the current updates, of course and that is complicated by this ‘Creators’ thing - but in any case if Windows is otherwise up to date, it sounds like, from what my colleague JB says, and he’s much more up on installer stuff than I am, you’ll want to UNnstall all of the Rhino components from Control panel and start from scratch from the full installer - something went wrong in the installation process. If that fails to sort things out, I’ll recruit the top dog to have a look.

@bjornsyse - before you do all of that, try running this file, assuming it is there:
“C:\ProgramData\McNeel\Rhinoceros\5.0\Packages\ui (any).rhi”

-Pascal


#7

Hi Pascal.

I tried that rhi file but it threw and exception. However, the next time I tried a complete uninstall and reinstall everything came in right. Crossing fingers here. (still don’t know if I have creators update)

Thanks for the fast support.

  • Björn

(Pascal Golay) #8

OK, good - thanks for the update.

-pascal