Toolbar Icons Missing! (Use ToobarReset to fix)

I’ve had Rhino 5 installed on my Windows machine for about two years now, and just this week I opened the program to find that all of the icons for my toolbar buttons were missing. The toolbars themselves are still there, and when I hover over them, it shows me what they are, but the actual icons themselves are all gone. It looks like this:

I’ve never had this problem before and I have re-installed Rhino to no effect. The problem started just after I tried to boot Rhino and for some reason it told me it no longer recognized the license for Orca 3D. I’ve re-installed Rhino and Orca and have had no luck.

I’m running a Windows 10 ASUS ROG with an NVIDIA GeForce GTX 860M.


We’ve been seeing this recently with some Windows 10 installs. Does ToolbarReset do anything for you?


PS… How do you like your ASUS? I am thinking the G501 will be my next laptop…


Life-saver! Yes, ToolBarReset worked perfectly, thank you.

The ASUS is alright. It’s an absolute monster for graphics, but in terms of processing power, it doesn’t really stand out. Mine is just over a year old and came with a standard 1TB hard disk and 8GB RAM. It had issues from the get-go, though, which I later had diagnosed as a bad hard drive. Replaced it with a Samsung SSD and upped the RAM to 32GB, now runs like an absolute dream, the most powerful PC I’ve ever used.

I’d caution you away from ASUS though, people have said they come with problems factory installed, which mine obviously did, with a bad HDD. Maybe they’ve fixed the issues, maybe not, but paying $2000 for a laptop that needs to have surgery a year later is just poor. I’d say go for something with more processing power, get one of the new unlocked (overclockable) Intel processing chips and build your own machine if you can afford the in-portability of a desktop. For the same amount of money, you’ll get a computer that performs to at least 1.5x the amount that a stock factory machine runs at.

Best of luck, and thank you!

The idea is to have a light portable for traveling as I’m tired of lugging around my 8 pound HP brick… Looking for a sort of a MacBookPro but made for Windows. I already have a workstation at both home and work; I’m not going to be doing monstrously heavy stuff on the laptop. The new ones come with a 512 SSD and 16 Gigs of RAM… Anyway, I’m still sniffing around, no big hurry, also looking at a Surface Pro, but I don’t really need a(nother) touchscreen/tablet…

Thx, --Mitch


Check out the Dell Precision M3800. I had them ship it with a 256 GB SSD boot drive and an empty 2nd drive. I then popped in a 1 TB Samsung SSD and it’s fantastic. The new model has a 4K screen and will drive a second monitor of the same rez. 16 GB RAM. Sweet.

Haha, not long ago you had other arguments… you remember?

A son of mine has a Surface3 pro i7 with 8GB RAM.
It’s not a toy for him, he works with it.

This thing is quite good and really portable.
It has Intel HD5000 graphics, not a performance bummer, but with my tests I didn’t find it is slow.
Try it, you will be surprised.


I have the exact same problem with my Rhino 5 which I fixed with a toolbar reset. However, my T-Splines toolbar icons are still missing! No one from the T-Splines forum has a fix for this either. I think it may be a Windows 10 upgrade conflict. I’ve tried rolling back to Windows 8.1, but I think the damage has been done. Since Autodesk purchased t-Splines, their support has been non-existent! Frustrating!

Hi Andrew- see if TS can send you a fresh TSplines RUI (toolbar) file and see if that looks correct- (open it via “Tools > Toolbar layout…”, or drag and drop.

Any luck with that?


Unfortunately, since T-Splines has been purchased by Autodesk and they are amalgamating it into their other products like Inventor, there is no support for T-Splines to contact and ask for a RUI install file. However, you gave me an idea! I manually loaded the TSplines.rui file from C:\Program Files\Autodesk\T-Splines for Rhino\TSplines.rui and the old TSpline icons came back on a separate set of T-Spline toolbars! It appears that the current install T-Splines build loads the TSpline.rui from C:\Users\YourName\AppData\Roaming\McNeel\Rhinoceros\5.0\UI by default which has a corrupt RUI file! I copied the good RUI file into new UI folder and it’s all good. Thanks for the idea, Pascal. You’re a genius!!!

@drewmatic I’m glad you got it sorted out - what I should have mentioned right off is that there is always a .bak of the rui files that are in use in the folder


So, deleting the corrupted one and renaming the .bak version may also fix things.


hi @pascal

I’ve updated window10 and when I restart rhino icon is not displayed

any solution? thanks

The standard fix for this seems to be to run ToolbarReset and restart Rhino. --Mitch

perfect! thanks

Hi Rhino 5 and windows 10 users.

I’ve installed Rhino 5 64 bit on a HP elitebook and I’ve got the icon problem as well.
Unfortunately the toolbar reset doesn’t work for me. I’ve even re-installed Rhino.

I’m working with the 90-day trial version, but I don’t think this causes the problem.
Anyone any ideas?



Hi Sander - do you mean your toolbar opens with no icons at all? If you run ToolbarReset, and restart Rhino, do you see that Rhino shows a little message in the upper left of your screen when it restarts? What happens after the restart, do you get any toolbars at all?


Hi Pascal,

indeed, it didn’t get any icons. But know after again a toolbar reset it works.
Sorry for the fuzz. I will continue modeling know.

Thanks for the respond.



I have been using Windows 10 with Rhino for abut 4 months. Until today I never had a problem with my icons disappearing. Now I am having to do a toolbarReset about every hour to get my icons back. Either Windows 10 has some serious problems or Rhino is starting really get on my nerves. This is becoming a big problem for me now. I have lost a bunch a customized icons that were pretty specialized even with some Python code I wrote. I am not about to try to redo them now until I find out if Rhino or Windows 10 is causing this headache.