No real-time preview of the texture position when moving the mapping widget in Rhino 7

If I use the _Move command in Rhino 5 to move a mapping widget of a texture you have a real-time preview of the texture position, which is great to visually pinpoint a texture. In Rhino 7 though you need to finish the _Move command in order to see the texture position update.
I find this rather cumbersome and I wish we would get back the Rhino 5 behavior.

thanks, Tobias

Hi Tobias - that is not the case here in Rendered display mode, in the latest.

Can you please run the SystemInfo command in Rhino and copy/paste the results here?


Hi Pascal,
Here a video demonstrating the issue:

System info:

Rhino 7 SR5 2021-4-10 (Rhino 7, 7.5.21100.03001, Git hash:master @ 2cd158094b595f6400479d7cbe511454b6149527)
License type: Commercial, build 2021-04-10
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Bongo 2.0 (64-bit)\Rhino6\Bongo.20.rhp “Bongo 2.0”
C:\Users\Tobias\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\InteriorBuilder 3.0\InteriorBuilder.rhp “InteriorBuilder”
D:\Profiles\Rhino\Rhino7\Plugins\RhinoFileVersion 707639.rhp “Rhino 3DM File Version” 7.0.7639.20582
C:\Program Files\Bongo 2.0 (64-bit)\BongoUI.20.v60.rhp “BongoUI20v60”
C:\Users\Tobias\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.0\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows”
C:\Users\Tobias\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Tobias\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.21.831\SectionTools.rhp “SectionTools”

thanks, Tobias

Hi Tobias - thanks, I do not see that here, running our in-house 7.7, so far, but I’ll go back to 7.5 and see.


Thanks Pascal! I wonder if it’s showing up on your 7.5… hope it’s possible to fix this.

Hi Tobias - here it does indeed work on 7.5. I see a lot of non-standard plug-ins in your System Info that I do not have … I guess we should start eliminating those one or two at a time and see if we can point a finger at one of them.


Talking about plugins…I don’t really get why Bongo is listed twice with 2 different names. Seems messed up to me. But I’m reluctant to remove it cause there was trouble to get it activated when I installed it

Because Bongo consists of those two plug-ins.

Oh ok. Than I haven’t said anything :sweat_smile:

Hi Pascal, I removed all non-standard plug-ins except Bongo. The problem is still there.
Any other ideas?

thanks, Tobias

Hi Tobias - just to make sure, you also closed and restarted Rhino after disabling the plug-ins in PlugInManager, …correct?


Yes I did! I removed them one by one restarting Rhino every time

OK, thanks. I was hoping I could find a flaw in your process. I don’t know why it is doing this for you and not here. Before I ask the bigger brains, can you send me the object, and texture, to try? Maybe my test is too simple.


Thanks Pascal for looking into the issue

Hi Tobias - can you send me a file with a object and its texture, that shows the problem for you?


I wonder if this has to do with Advanced Texture Preview maybe. In case you have fiddled with display mode settings it may be good to try restoriing them to their defaults and see if this improves.

Hi Nathan,
You were right that it had something to do with the rendered display mode settings. “Advanced Texture Preview” made no difference but I had “Use advanced GPU lighting” off. Turning that on fixes the issue.

Thanks for pointing me in the right direction!

Good to hear this got resolved.