No more GH Icon

the tool to make icons for Grasshopper in Rhino 8 seems to not work ?
Is it on purpose ? I thought this tool very useful to make icon.

Rhino 8 SR7 2024-4-22 (Rhino 8, 8.7.24113.23001, Git hash:master @ 6d95a2bfe831b9dd0ef81b6e220b294af59416ca)
License type: Commerciale, build 2024-04-22
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.15

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 10-26-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.01
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port 0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-26-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\SimLab\Plugins\SimLab 3D PDF From Rhino 6\plugins\SimLabPDFExporter.rhp “SimLab PDF Exporter”
C:\Users\LaurentDelrieu\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\Grasshopper2\2.0.8715-wip.22923\Grasshopper2Plugin.rhp “Grasshopper2” 2.0.8715.22923
C:\Program Files\Geometry Gym\Rhino8\BullAnt.rhp “bullant”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”
C:\Users\LaurentDelrieu\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

Any news, I really enjoy this tool that is super useful.

Hi Laurent -

The panel appears to be called “GH2 Icon” and has a different icon than what you show in the screenshot.

1 Like

Thanks, it must be in the new release from today !

Logged in as Laurent DELRIEU
Version 8 SR7
(8.7.24113.23001, 2024-04-22) Commerciale

Still not in this version or does I miss something

Hello Wim,
I uploaded last version and still no GH Icon
Version 8 SR7 (8.7.24128.12261, 2024-05-07) Commerciale

@laurent_delrieu that’s odd. You might try a Repair of Rhino.

1 Like

This is part of grasshopper 2. Do you have the latest version of GH2 installed?

@stevebaer I think I have

@Gijs I will try that.

Thanks for your answers.

I did install the last version and make a repair and now no more GH ICON

@DavidRutten is is in a new GH2 version that is not online ?

just to be sure, that one only appears after you fire G2

G2 is still there and works, I have all theses commands in Rhino

G2IconSetup works !!!
I don’t know if it was the use of G2IconSetup but now I have the Panel