No language found in Py3 component

Hi Ehsan!

Japhy mentioned that you might help with my GH/Python problem.

My problem is related to the use of Python 3 in Grasshopper.

I have Python 3.12.1 installed on my system (installation confirmed through cmd.exe → “python --version”) and I am using Rhino 8 SR3 (8.3.24009.15001, 2024-01-09).

If I open Rhino and GH and try to add a script-component or even a Py3-component an error message occurs: 1. No script to execute. Choose a language from component menu.

It worked once, when I started Rhino with admin-permission (Rhino also changed its appearance from dark mode to standard, stadard toolbars, etc). The component worked fine then.

But now I get the error message again - even if I try to use admin-permissions again. Rhino does not change the appearance at all and also the components don’t work like they did once.

Do you have any idea how to fix this problem?

Thank you for your help.

Do you see the other language-specific components?

Rhino_mr9OmXgHSp

Also would you mind posting this on the forum so others can benefit from reponses as well?

Thank you Ehsan, thats a good idea. I posted it right here:

To answer your question: Yes, I can see them. But except VB, they all have the same problem.

@Modeller Rhino ships its own version of Python 3 (3.9.10) and does not use your system python.

Please launch Rhino, run the RhinoCodeLogs, save the contents and DM the contents to me please. Also please make sure RhinoCodePlugin is loaded in PluginManager

Unfortunately in the PluginManager RhinoCodePlugins checkbox is deactivated. I can activate it by activating the checkbox - but after accepting the change in the pluginmanager by clicking OK it resets again. If I open the PluginManager again the RhinoCodePlugin is still deactivated.

Might this be the root of the problem?

If the plugin is not loaded that is definitely the problem. You can right click on the plugin and select “Load Plugin” to load it in the current session. If the plugin does not stay open that seems to be an issue with Rhino saving its configurations. Are the Rhino settings managed by your company admin?

It is the only Rhino installation in our company, so I don’t think they have any influence on the Rhino settings, but maybe some system specific settings could be the problem. Is there something I could look for?

Hi Modeller,

Can you post your current SystemInfo?

Lets get you on the latest. Please go to Settings/Properties>Updates and set your update frequency to Service Release Candidate.

Thanks

1 Like

Hi Japhy, hi Ehsan,

seems like I found a way to make it work:

I opened the PluginManager an copied the path from the not-working RhinoCodePlugin and installed a “new plugin” using this path. For now that works and also my GH shows me the scripting features.

Thanks for your help!

1 Like