Ghpython Not Found In Grasshopper

Hello I can’t find Ghpython in the script menu of Grasshopper 1.0.0007 (Rhino 7). I downloaded Ghpython2 from food4rhino and copied it to components folder yet it doesnt load.

You shouldn’t need to install GHPython for Rhino 7 as the component ships with Rhino/Grasshopper. I would recommend removing the gha that you copied to the components folder as it may be causing a conflict.

1 Like

Hello , thanks for the reply!
I removed it from the components folder and restarted my laptop , still the same problem persists!

Did you restart Rhino/Grasshopper?

Can you run the “EditPythonScript” command in Rhino?

1 Like

Yes @stevebaer Sir I restarted Rhino too! Yes, the “editpythonscript” command works fine in Rhino. How can I run it in Grasshopper Canvas?

Hmm… it should just be there. Did you install other components? Maybe they are causing problems. You could try the GrasshopperLoadOneByOne command to try and diagnose the issue
https://docs.mcneel.com/rhino/7/help/en-us/commands/grasshopper.htm#GrasshopperLoadOneByOne

1 Like

Hello, Updating to the latest version of Rhino solved the problem!
Thank you for the support! Cheers! :beers: