::No Grasshopper in Rhino V5 any more!::

unhandled

#1

Hi guys,
I have Rhino V5 and V6 as a trial installed, however it seems that I cannot use Grasshopper in Rhino V5 any more. In V6 works fine with the latest update, but in in V5 when enter the command “Grasshopper” it result as unknown command.
Any advice to help solving this?
Thanks,
Elshar


(David Rutten) #2

Unexpected, but as long as Grasshopper is still installed, you can always reload it manually via the _PluginManager command. Just locate the GrasshopperPlugin.rhp and load it.

If however you are now getting loading errors then there should be more information in the command line.


#3

Hi David,

I reset my laptop last night due to some issues. Then I reinstalled Rhino 6 and started working fine on Grasshopper, never experienced any issues.

But then this morning, I started a new document and started add components but whenever I try to add PANEL through the text command (")to the canvas Rhino crushes. I still can add PANEL through the menu, but also whenever I double click to add values or texts, Rhino crushes again.

I tried this multiple times, but still the same crush in the end.

Elshar


(David Rutten) #4

Do you get a crash report dialog? If yes, please send in a full report with a description including the words “Grasshopper” and “Panel”. With a bit of luck I’ll be able to harvest some useful information from the crash dump data.


#5

If I recall/understand correctly: Rhino V5 trial will no longer load plugins if the trial period has expired (90 days), including Grasshopper.


#6

Hi David,
I sent the CRD.
Best of luck!


#7

Hi Anders,
I have the commercial version of Rhino V5 and the trial version for Rhino V6.( I should described it well I guess).
And I could load Grasshopper manually as David suggested and now working fine.
Thanks
Elshar


#8

Hi David,

Any update about the panel’s problem?

Did you find any possible reason that makes Rhino crushes whenever I use it, or better a solution?!

Thanks,

Elshar


#9

RhinoCrashDump.zip (13.7 MB)
Crush Dump File


(David Rutten) #10

I think I found it (same user name). It appears to be a crash in Bubble. I don’t know what that is, but do you have that installed?


#11

Yes. I recall I have installed the plugin Bubble that night. Could it be the reason?
EDIT: http://www.food4rhino.com/app/bubble
Capture


(David Rutten) #12

The crash report has a very short callstack (that’s the program operations that led up to the crash) but Bubble is in there.


#13

Hi David,
I just disabled Bubble, and tried loading Grasshopper and using the panel. It seems working fine now, with no crush.
Elshar


(David Rutten) #14

Thanks for testing, the Bubble devs have been informed of the crashdump and this conversation. They may get back to you at some point, or maybe there’s enough info in the database now to just fix it straight up.


#15

Sure!
And thanks for checking the file and be responsive about it.
Elshar