No dropdown menu/options Top, Perspective, Front and Right

I am new to Rhino. Suddenly, the drop down options when I right click the different view tabs (top, perspective etc) which used to show for example “Wireframe/Shaded/Rendered” etc are mising. I can only switch between viewports, and to change the look of the viewport I can go to the top View menu. But I am wondering what I have done to switch off the options for right clicking the viewport tabs.

Any help much appreciated. Thank you

Hello - just to be sure I follow - the viewport labels are there, correct? If so, do you get the menu from a Left click on the down arrow next to the viewport name?


Yes thank you. The view port labels are there. No I don’t get a menu from a left click. It was working for a few days and stopped at some point today.

Hello -

Please run the SystemInfo command in Rhino and copy/paste the results here.


Thank you
Rhino 6 SR24 2020-3-19 (Public Build, 6.24.20079.23332, Git hash:master @ 064283610b834170e52117f2656605b5b25d65c0)
License type: Evaluation, build 2020-03-19
License details: Cloud Zoo. In use by: Soraya Gilanni ()
Expires on: 4361848-04-01

Apple Intel 64-bit macOS Version 10.14.6 (Build 18G103) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro11,1
Machine name: Soraya’s MacBook Pro
Language: en-GB (MacOS default)

Intel Iris OpenGL Engine (OpenGL ver:4.1 INTEL-12.10.12)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Graphics: Intel Iris
Displays: Color LCD (227dpi 2x)

Graphics processors
Intel Iris (1536 MB)
Color LCD (1280 x 800)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices

Third party kernel extensions
com.Perfect.Driver.SystemAudioRecorder (1.0.0) 006E5F93-3F76-3B8B-BF63-0EB171665EA5
com.getdropbox.dropbox.kext (1.10.3) F29DD0CB-48D6-311A-9B69-E39CF775493C
com.malwarebytes.mbam.rtprotection (3.7.34) C8FC616A-49CC-3018-8759-F5061BD365F3

Third party plugins

Rhino plugins
/Applications/ “PanelingTools” 6.24.20079.1002
/Applications/ “Grasshopper” 6.24.20079.23332
/Applications/ “IronPython” 6.24.20079.23332
/Applications/ “Commands” 6.24.20079.23332
/Applications/ “Snapshots” 6.24.20079.1002
/Applications/ “RDK_EtoUI” 6.24.20079.23332
/Applications/ “Displacement” 6.24.20079.1002
/Applications/ “Renderer Development Kit” 6.24.20079.1002
/Applications/ “Rhino Render” 6.24.20079.1002
/Applications/ “RhinoCycles” 6.24.20079.23332

Can you run the newer Mac OS on this machine? If so, I would update.


Have you tried Quitting Rhino (Cmd+Q) and restarting?
Another option might be resetting your Rhino PLIST if restarting doesn’t help.

I will try updating the OS tonight. Yes I have quit and restarted. I’m sorry how do you reset Rhino PLIST? Thanks

Thank you John. Unfortunately this hasn’t worked.

Hello Pascal, I have now updated OS and it still is not working. Do you think it’s because I’ve got an evaluation copy of Rhino? Thanks, S

No, that’s not the case. I’m also running a evaluation of Rhino and everything is working as expected, so it must be another thing.


One other thing to try…

In Rhinoceros > Preferences > Display modes,
Select a working display mode name (like Wireframe), and in the User Interface options section, is the top box checked to “Include in View’s display mode menu”?
This option should be checked for all of the working display modes.

They are all ticked. thank you. Still not working.

And you are 2-finger clicking (trackpad) on the viewport’s name?

Oh dear! That explains it I had convinced myself I had to right click. So sorry! Thank you

Right click would be a with a Mouse or in Windows Rhino.
2-finger click on a trackpad.

Thank you